Odroid N2 test builds

No reason it should be broken and we can’t diagnose your issue without logs.

Is there any investigation in CEC Wakeup Problem ? Or any solution which i might have missed?

Today’s update has problems. It wont allow me to boot the N2. It does boot if i press the ESC key on repeat on boot. Gives an error real quick. Says something not found. Tried to record a slow mo video about it, but was too small.

When it finally boots, tells me that there is an update ready to install and all over again. Will erase the update when i get back home and wait for the next update to apply manually

Check this topic: Nightly builds

Connect the N2 directly to your television, remove all other HDMI connected device and try CEC suspend/wakeup.
It will work.

Thanks. I didn’t know that thread existed. Bookmarked!

Any info regarding why the latest nightly will lead to no boot?

Ok, in the end after a couple of restarts it booted ?!
Any idea what was the reason for it ?

Guys, something is wrong with the latest nighly builds…, after finally it booted, it showed that a new update is available. After restart, it sits again with the Coreelec logo, but this time no error code. I’ve tried restarting it twice, but nothing happens. After again serveral restarts, it boots again. Now it’s on 09.11 nightly.

Thanks. I just saw in the other thread that it was already posted. Will try it once I manage to make it boot again…

Now it’s fine, thanks.

I can not find the covers/infos of my new movies, do you know why? I did not change any settings (TMDB) …

i did not yet try that but i am wondering what you want to say. coreelec/odroid is not able to handle CEC correctly? because the raspberry did not have any problems with my setup (which is - i guess - a very common one)

edit: just tested it. the behaviour is as i expected.
when the tv has its input on hdmi1 and the odroid is connected to hdmi1, it works. but as soon as the default hdmi input is e.g. hdmi2 on the tv/avr, the odroid simply ignores that. when i explicit select hdmi1 on the tv as input source (even tho its greyed out because its not recognized), the odroid wakes up, otherwise never. so its exactly the same behaviour with the avr - i have to select explicit the channel, otherwise the signal seems to be ignored.
the raspberry woke up no matter which hdmi input was the default one in my tv or in the AVR.
as this happens on both sides (avr and tv), i assume thats not an error in the avr/tv but in coreelec or in the odroid.

1 Like

I also have CEC issues. Waking up when turning on the TV works fine for me, but sometimes the remote is not forwarded to the N2 afterwards. I then have to switch to another HDMI input, wait 1-2 secs, then switch back to the N2 to make the remote work. The N2 is directly connected to my TV and other HDMI devices (e.g. PS4) work without issues and always have the remote working properly.


I am changing this (CE 9.2.0) with notepad ++, no automatic update. And disable the blue led but none of the 2 things works. Any help / suggestion? Thank you

Did you remove # character ?

# enable_system_power=0 -> no effect
enable_system_power=0 -> effect

1 Like

surely that is, I forget to remove them. thanks i will try now

now yes, i forget this :sweat_smile::sweat_smile::sweat_smile:

thanks team, petitboot and coreelec best things in N2 :grinning:

1 Like

Does that then mean we cannot have any other device linked to our TV while using a N2? Seems a bit of a harsh workarround no?

For me I got my Set-top box connected and a N2 to my TV directly on different HDMI ports.
When I go from my settop box to my N2 it sometimes picks up on it but most of the time it shows the N2 but the command is actually still going to my settop box. Switching sources a couple more times or disable/enable CEC on my TV itself wakes up the N2