Only 2ch Audio when playing files from Amlogic S905X2 Mecool KM3

I recently got a Mecool KM3 which runs on Amlogic S905X2 to help play TrueHD atmos content on my AV receiver because my TV could only support DD+ Atmos max. I’m new to coreelec and TV boxes but I did manage to install coreelec on a 32GB SD card and boot it properly on the box from the SD card. All video files (HDR, 1080p, 720p, etc) are playing well but the problem is audio. The only audio that I can manage to play from the box is 2ch audio either after configuring it to play 2ch audio only or by playing files that have 2ch only. If I configure the audio settings to more than 2 channels and then I try playing something like a file with 5.1 ch, I get nothing on audio. I even removed the SD card and booted to normal android OS and I still have the same problem even after enabling passthrough on both OS and selecting all the options on the audio passthrough settings (I even tried deselecting them one by one). My receiver is an Onkyo TX-NR686 and my speaker configuration is on 5.1.2. When I play different audio files from the TV connected to the receiver, I can get upto 5.1 audio and 5.1.2 DD+ audio. Even the TrueHD atmos files can be played from the TV but will get recoded to 5.1 since the TV only supports DD and DD+. But the problem is, when playing anything from the box, I can only play 2ch audio content or I have to set the audio settings to 2ch audio in order to be able to play any 5.1 or above in 2ch instead. I don’t know what I’m doing wrong. I’m sure my HDMI cables are good (from receiver ARC output to TV ARC input I’m using a PS4 HDMI cable and from the box’s HDMI output to the receiver’s HDMI input I’m using the HDMI cable that came with the Mecool KM3 which I also tested on the TV-receiver ARC connection and it worked just as well as the PS4 cable. All of the receiver’s HDMI inputs have HDCP 2.2 and I’ve also tested the box on the other HDMI inputs available on the receiver including the Game HDMI input where I normally put my PS4 and get 5.1 sound but still the box only gives out 2ch max. What am I doing wrong? what else can I try?

You need to enable HDMI passthrough in the System -> Audio settings. Make sure you’re in Expert mode in that menu.
Keep channels at 2.0, as S905X2 Multichannel L-PCM is currently broken and we’re working on getting it fixed.

Already did enable HDMI Passthrough in expert mode and enabled all the options that my receiver is capable of handling. I even tried to disabling some to see if it would help but nothing. I’m still getting only 2.0. Anyway, I guess I have to wait for a fix. Thank you.

If you enable HDMI passthrough, and select HDMI as the output device, it should work.
There are no known issues with HDMI passthrough, on any devices.

Actually, I have to disable passthrough in order to get the 2.0 Audio in all file formats.

Don’t know what you’re trying to accomplish, but I suggest you reset and start over.
Passthrough works fine.
Multi channel pcm doesn’t, but if you’re playing content like Dolby digital or dts, your avr should play it without a problem via passthrough.

Check that Settings - > Player - > Videos - > “Sync Playback to Display” is off !!!

Guys, I figured it out. OMG. It was the HDMI cable! like wtf! The cable that came with the box wasn’t passing through the HD audio signals. I used a different HDMI cable and bam. Everything now works. TrueHD, DD+, DTS:X Everything works. lol. I’m so sorry to bother you guys.

1 Like

You would be amazed how many times the cable is the problem.

1 Like

Is this still the case or is it safe to set to 7.1? For s905x3 in my case using nightly build

Support for LPCM has been added a long time ago, you just need to select the right audio device in the Audio settings.

1 Like

Thanks and forgive a noobie question. I am trying to get my onkyo to get atmos passed through. In the manual it says to set the source as bitstream. Would this LPCM be want it wants? Or is there another way to make it bitstream to get atmos going?

No, for passthrough, you need to enable the option in the bottom, and select HDMI.
LPCM is only for formats that cannot be bitstreamed, such as AAC or formats your AV equipment doesn’t support.

So anyway, today I decided to try out some AAC audio files after a long time ( I had completely stopped getting any video files that have them after I thought that I could never play them on my s905x2) I set my audio settings to HDMI Multi Ch and set the no. of channels to 7.1 as per my receiver and voila. Now it picks up even AAC perfectly. Dunno if it was because I wasn’t doing it right the 1st time or some changes were made but all audio file types work fine now.

Hi everyone, this post is old but I though I’d ask the question here since so many of you had great ideas for the questions about Mecool KM3 audio…

My question is do you know any workarounds to get audio from the KM3 to traditional old school RCA cables so I can patch it into our traditional (non digital) receiver?

I’m replacing an old Zoomtak android tv box that has rca audio outs and works perfectly with our stereo. But the KM3 doesn’t have rca out.

Thank you! :smiley:

You can get a HDMI to analog splitter.
Or if the box has SPDIF you can get a SPDIF to analog converter for a few bucks.

Which has less delay? Or are they about the same?

Don’t know, depends on the DAC in the specific device you chose.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice