PER, SNR and Signal Strength "Unknown" on TVHeadend

8 of the 16 DVB-T/T2 TV channels which work on Android on this Kii Pro mecool box, are working in Coreelec with TVHeadend. In an effort to determine why I am missing channels and have failed muxes, I wanted to look at signal strength. What would cause the values for PER, SNR and Signal Strength to be listed as “Unknown” on the status line of TVHeadend? HTS Tvheadend 4.2.8-27 ~ CoreELEC Tvh-addon v9.2.120. The interface is Avalink Avl6862

It works for me, try using the other driver I think I use the kernel Driver

see this thread

If you are in the UK you will get the Main MUX (BBC1 HD,BBC2 HD,ITV HD etc) to get the other muxes to work you need to clone the working mux settings and change the frequency to the non working one. PS in the Granada muxes changes frequencies today.

I think I loaded the kernel drivers. Not sure and I cannot find the dialog again, but it did say kernel and dvb. Uninstalled the server, reinstalled. During the wizard it found 9 muxes and showed signal strength between 83-90 percent, SNR of 0 while it was scanning. Immediately after the scan, it went back to Unknown, but now it is showing SS of 89, but all muxes failed. One that worked last time was not listed, so I changed the frequency manually of a failed one and that one came up OK. I have ordered that Xbox tuner to see if that gives a different result. It’s only 12 euro. Is there a way to delete all settings to start over instead of uninstalling and reinstallilng? A few minutes later, I now have my original 8 channels working, and also I also see SNR of 44 and SS of 89. So, at least that works now. Just have to figure out why these muxes are failing. I have about 8 or 9 channels I can see under Android, but not under Coreelec.

I have the xbox tuner too. I find in the uk it is fine for the Primary HD mux but the other two muxes are unreliable on it. The Averlink is the only reliable one for me on all muxes but you need to enter the parameters manually. The only correlation I have found is the HD channels that don’t work are on the same mux as some SD channels. The HD Mux that works out of the box is the one with only HD channels in it.

The drivers are in addons>program addons>CoreELEC Module drivers. It Only shows signal strength and SNR when tuned into a channel.
To delete all the settings remove the addon and delete the \coreelec\Userdata\addon_data\service.tvheadend42 directory.

Problem solved, but I think it is too late to stop the shipment of the Xbox tuner.
For boxes like mine with the Avalink6282 identified as the DVB receiver, it appears to be CRITICAL to select AUTO for ALL parameters except for Bandwidth in the muxes. Once I did that, and selected “DVB-T2” as Delivery System, all of my weird-acting muxes (“OK”, but no services, or “Fail”) came up with their correct services and mapped without issues.
I had read somewhere that usually Auto is not okay, but I had tried Auto on some parameters, but not EVERY parameter.
What clued me in was “w_scan -ft -c DE” (DE=Germany), which came, I think with my installation of dvbtools. By running w_scan, via SSH over Putty after shutting down Tvheadend (“systemctl stop services.tvheadend42” use “restart” in place of stop to resume), I was able to see w_scan literally tell me which parameters could be set to Auto. And that is what I did. w_scan also confirmed precisely what services were available on which channel. Many days to figure this out. Next up, getting the PVR working and shares to my qnap to see photos, etc…
For the sake of others with similar gear and problems, I’m going to salt this post now with additional relevant keywords for Google: Kii Pro mecool 2gb/16gb Coreelec 9.2.120 Mux Fail failing 4.2.8-27 no services Germany Deutschland Berlin. 506Mhz 7 Services, 570Mhz 5 and 626Mhz 16 (10 are not video) That ought to do it.

Do you know if there are drivers for the Xbox tuner under Linux? I don’t need to use it on the Coreelec box. I can’t find drivers for this anywhere.

xbox tuner works on tvheadend on x86/x64 linux its been a couple of years since i did it but i seem to remember needing to download the firmware

Thank you very much. I will try it again tomorrow. I put it on Linux Mint 19.x and, of course, it was not seen by TVH. I tried to update the kernel on Mint to 5.37, thinking maybe some drivers might be in there, but the kernel would not update.

make sure you have the firmware

When I did it it wasn’t in the kernel I think I recompiled media build but that may have been for my TBS tuner.

Couldn’t get the tuner to come up. I put the firmware file in the directory, rebooted with the card plugged in, but no tuner shows up. I’m using Linux Mint 19.x (Tara, I think?). It’s not a big deal. I just wanted to have experience with another tuner before I pack it back up and return it since I don’t really have a use for two boxes.
PS Have a good weekend!

I upgraded to kernel 5.3.6 and after that, the xbox one tuner was seen immediately without the firmware addition. But I could never get any muxes to com up except for one:the shopping channel. Sending the tuner back since I don’t have anything I can do with it, especially if I can’t get past mux FAILs.

Have you tried adding one of the CoreELEC Module Driver packs to see if this makes a difference as despite it seeming to be picked up, perhaps there are still elements missing to fully enable the tuner?

Is it possible to install Coreelec on Linux? Is that what you meant?

Ignore me lol

For a moment I was thinking that you were referring to a CE installation and not Linux.

No worries! It’s all good.

Use this version of Tvheadend if it doesn’t work enable the crazycat driver and everything will work perfectly.