Problem with activating Remote.conf

Hello People,

I’m new with coreelec, I install it on a X96 Max Plus, the System itselfs runs great but i don’t get any remote to work.
I made a xml like in this tutorial and create the conf in the folde /storage/.config/ and put the xml in the folder /Storage/.config/rc_keymaps/.
Now I want to load the config to coreelec but when i type “ir-keytable -a /storage/.config/rc_maps.cfg -s rc0” I get the message of no such file or directory.
I do a list of the directory and I only get the directorys “Lost + Found”, “movies” etc. but no System directory to bind in the config.
Could anyone help how i get the config into coreelec?

P.S.: I made the directory in windows on the Stick, I don’t know if i must have an directory “Storage” or if it is enough to make the directory “.config” on the root directory because “Storage” is the root.


You did it the wrong way.
/storage is a linux formated partition

/storage folder is on second partition, which is not visible from Windows.

You can put your conf file to flash partition (the one you see on Windows and holds files kernel.img and SYSTEM). Then boot from this stick and use ssh to copy files.

cp /flash/YOURMAPNAME.toml /storage/.config/rc_keymaps
echo "meson-ir * YOURMAPNAME.toml" >/storage/.config/rc_maps.cfg

I copied the files through smb from network in the config folder and do the command with putty on ssh
in the configfiles directory also is a rc_maps.cfg_sample so I think it’s the right folder.

I think you missed this part

CoreELEC 19 change
For CoreELEC 19 YOURMAPNAME needs extension .toml. The whole filename is then YOURMAPNAME.toml

So I not name it “rc_maps.cfg” but “rc_maps.toml”? I don’t get it. Sorry I’m a total noob with this.

No. Created config file is named YOURMAPNAME.toml - of course YOURMAPNAME is just an example and can be something else too like myremote.toml.

Then you need to put this file in folder /storage/.config/rc_keymaps.
And you also need to create file /storage/.config/rc_maps.cfg. One option is with this command in ssh

echo "meson-ir * YOURMAPNAME.toml" >/storage/.config/rc_maps.cfg

or you also put file over smb.

Oh ok, so my keyfile where I put the Keys in is the *.toml-File not the config, must I note something or can I simply name the file from xml to toml?. And in the config i set the Path to the *.toml-File?

What you get when you type this commands?

ls -l /storage/.config/rc_keymaps
cat /storage/.config/rc_maps.cfg

Ok, type this 2 commands and then you will have set as it should be.

mv /storage/.config/rc_keymaps/X96MaxPlus /storage/.config/rc_keymaps/X96MaxPlus.toml
echo "meson-ir * X96MaxPlus.toml" >/storage/.config/rc_maps.cfg

But you didn’t said which CE version you are using? CE 9.2 or CE 19 ? Above is for CE 19!


Now I get this Error when I do the command, any suggestions?

rc_maps.cfg (27 Bytes) X96MaxPlus.toml (488 Bytes)

These are my files now after the command.

Use this for X96MaxPlus.toml. This is the format needed for CE19.

name = "x96maxplus"
protocol = "NEC"
0x14e = "KEY_1"
0x10d = "KEY_2"
0x10c = "KEY_3"
0x14a = "KEY_4"
0x109 = "KEY_5"
0x108 = "KEY_6"
0x146 = "KEY_7"
0x105 = "KEY_8"
0x104 = "KEY_9"
0x101 = "KEY_0"
0x142 = "KEY_DELETE"
0x147 = "KEY_SUBTITLE"
0x143 = "KEY_MENU"
0x118 = "KEY_VOLUMEUP"
0x111 = "KEY_HOME"
0x150 = "KEY_RIGHT"
0x151 = "KEY_LEFT"
0x116 = "KEY_UP"
0x11a = "KEY_DOWN"
0x113 = "KEY_ENTER"
0x119 = "KEY_BACK"
0x14c = "KEY_OPTION"
0x140 = "KEY_POWER"
0x159 = "KEY_REWIND"
0x100 = "BTN_MOUSE"

Ahhh Ok, how should anyone know that there are so many Changes in coreelec 19? But now it runs and the Remote are functionable.
I only must find out how i can do a wake up with the Remote Power button, this is not working.

THX for the Help so far.

I just added notes for CE 19 in this instructions: How to configure IR remote control

If you have any suggestion to change let me know.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.