Problems installing CoreElec on MECOOL KM9 Pro (x905x2)

Hi all,

I’m having problems installing CoreELEC on MECOOL KM9 Pro (x905x2, 4gb). I use g12a_s905x2_4g.dtb. Have also tried g12a_s905x2_2g.dtb, just in case.

When I insert the SD card and boot with the “Toothpick method” I get the MECOOl splash screen after which I get a complete black screen. I get the same “error” when I simply boot with the SD card inserted (not using the toothpick). The CoreELEC logo never appear. I have succesfully booted in android recovery using “Toothpick method”.

I’m not able to run ‘reboot update’. In Termux I get ‘unknown command’. In Qute Terminal I get ‘permission denied’. I’m in developer mode as well.

Any ideas on how to solve this?

It seems that others have been able to install CoreELEC e.g. Installation on Mecool KM9 Pro

My setup:
MECOOL KM9 Pro (x905x2, 4gb)
Android 9, Google Certificated Voice Control Android TV Box
Burned CoreELEC using Rufus onto SanDisk Mirco SD HC 8GB (previously used on LibreElec with Raspberry Pi).
Tried two different HDMI cables, both work when booting into android.

A post was merged into an existing topic: Installation on Mecool KM9 Pro