Problems with installation on GT1 (Solved)

Hi, i had a working installation on Beelink GT1 and for some stupid reason I decide to update firmware and no I cannot go back to CoreELEC.
I’ve tested tree different sd cards but cannot boot into coreElec. Have tried toothpick och terminal reboot update and I can see that box is trying to boot from SD but nothing happens.
I use CoreELEC-Amlogic-ng.arm-9.2.2-Generic.img and have tried both Rufus and balenaEtcher and 3 different SD cards with same results.
I can boot other original firmware images made with Burn_Card_Maker and I also can access TWRP meny from my current Android firmware. I’ve tired both Beelink stock firmware and Android 7.1.2 but cannot get CoreELEC to boot from any SD. I also tried different device tree but that did not make any difference

Where can I download older images than 9.2.2. ?
What more can I try?

Bah, i found the 9.0.0 image CoreELEC-Amlogic.arm-9.0.0-Generic.img.gz
It works like a charm, spend 10 hours fiddling with 9.2.2

Could you please check why 9.2.2 does not work while 9.0.0 is OK from first run?

I’m ashamed, how could i missed that there is no dtb.img in 9.2.2 and my copy of the right device tree was not renamed.

My bad guys, please go on …