[REGRESSION] Long Press menu doesn't work

I’ve been using CEC for ages now, however I can’t add any sources because I can’t long press anymore on the device remote. Native IR is also super jumpy and seemingly broken on the latest build. This worked on kszaq’s LibreELEC builds no problem.

Hi KyleS,

there are many Threads about the CEC and IR. My Philips TV have a OPTIONS Key. So i will send special command.
But better will be a remote File. Do you have a Playerremote or a Multiremote?

No go on the Sony remote using CEC; tried every button.

On the native device remote I used to just hold down OK (enter) and it would pop the menu up after a couple seconds. Now browsing around I get double IR command entries and it’s a complete mess. :frowning:

Prehaps either of these PRs are a pile of crap? https://github.com/CoreELEC/CoreELEC/commit/d353e2641383769aaeddb661cf261d1668942e15


i dont know the Sony TV. My Hardware is a Philips and a Harmony Remote.

@KyleS neither of those PR’s affect our builds in any way as they are not applied to our kernel.

As for your device remote jumpyness I suggest you read the remote threads regarding changing the delays, it is not broken it’s just because of your lack of configuring it properly that you are getting poor results from it.

As for long-press via CEC I have never known this to work however Samsung remotes have a Return button which usually brings up the context menu allowing you to edit sources.

What? This was working perfectly on kszaq’s builds. There’s clearly a regression somewhere as /etc/amremote is now missing.

@KyleS I misread your first post, I thought you meant long-press via CEC did not work.

Long press via the device remote DOES work, you just have not configured your remote configuration properly as stated in my previous post, please look at the thread NEW Repo for Remote files (Thanks to Betatester).

There is some examples of how to configure long-press for the device remotes.