Remote configuration hell

I’m trying to create a satisfactory remote configuration file for my device. At first I thought the premade one I downloaded was mapped slightly wrong and a few simple edits might be able to make things right. Boy was I wrong. The person that mapped the remote’s keys did a great job. The problems seem to go much further than that. Major complaints:

Pressing backspace while you have an on screen keyboard open makes the keyboard close, losing an ip address you painstakingly typed in using the arrow keys and enter because of the next complaint…

Number keys are mapped to a T9 typing configuration, like texting on an old cell phone. It’s great that this is an option. But it should be that, an option. I want to get a number on the screen when I press a number on the remote. I tried changing for example KEY_NUMERIC_1 to KEY_1 but it’s the same thing.

Mapping most kodi keyboard shortcuts to buttons does absolutely nothing. Like o for example. I was really excited to finally be able to open up and view the codec information in kodi by mapping it to buttons on my remote that so far have been unused. I tried doing that with KEY_O but guess what that does? Nothing. Why? I tried copying in this: to the userdata/keymaps folder hoping to get a more normal kodi keyboard map but it’s just the same.

It’s nice to have but since there’s not really any documentation on what any of these things do I’m completely baffled about how to proceed. If nobody else has a satisfactory answer maybe I’ll make a project of mapping every key to the remote I find that has the most buttons and documenting it myself.

Perhaps someone can help. What device, what remote file did you download, & have you read the instructions regarding, how to configure from scratch?

My device is the M8S Mini, the original not the II. Quite an obscure device. I can’t find pictures of it on google. The file matches my device perfectly though. I verified this by following the directions to configure from scratch.

did you try any other from NEW Repo for Remote files (Thanks to Betatester)

If you install one of the later nightlies, you could try installing remote.conf

Have a look at this