Report about Amlogic S905X4 HK1 RBOX X4

@clarkss12 please try these dtbs and report what does work and what does not work, thx.

To test with each single dtb:

  • All USB ports working or not?
  • Wifi working or not
  • Power down does work or do the device reboot after shutdown?

I tested all four of the images that you posted. NONE of them would work. As normal, I changed the image to dtb.img and replaced the existing one in the sd card. I tried just powering on the box with the newly inserted sd card with the new dtb.img, but never got the CoreELEC boot screen. Then I tried the tooth pick method by depressing the reset button inside the A/V hole, same thing, would not boot.

After testing all for of them, I used this original one and it booted straight from a power up…
The original one works >>> sc2_s905x4_ugoos_x4.dtb

These 4 will not boot up…

sc2_s905x4_4g_1gbit_v1 would not boot.

sc2_s905x4_4g_1gbit_v2 Would not boot

sc2_s905x4_4g_1gbit_v3 Would not boot

sc2_s905x4_4g_1gbit_v4 would not boot

Not sure if the dtb.xml file is causing the issue, perhaps I should have deleted that file… Or I have a lot of spare microSD cards, I could test from scratch.

Can the YouTube app in this box support 4k?

I took a different microSD card and using the same procedure of burning the CoreELEC image using “Etcher” to create the CoreELEC OS. Then I used this imagine file and used it as the dtb.img. sc2_s905x4_4g_1gbit_v4.dtb

Something, it would not boot.

YouTube installs, But, as usual, it requires an api… So, without that api, it does not work.

I also have the Mecool KM6 Deluxe, but since it has a looked bootloader, I never bothered to try CoreELEC, either from an sd card or internally.

Do you boot from uSD or USB?
If USB you have one USB memory device with LED? So you can check if there is 5V power on the USB port?

Can you please try it on the Mecool KM6 Deluxe please. My current Mecool M8S Pro have locked bootloader and it can still boot CE from memory card and running great. If KM6 Deluxe can boot CE from memory card just like the M8S Pro, then that’s the box I would buy as it’s Google certified so at least I can get YouTube in 4k with the android part.

1 Like

I will be away until tomorrow afternoon or evening

I using microSD card

Ok, than I found the issue. Try again and test these 4 different dtbs:

Test run today, June 1, 2022

sc2_s905x4_4g_1gbit_v1 works…

powers backup after shutdown. >> Yes

5volt output on USB ports >> yes

5GHz WiFi works >> yes

Stock IR remote work >> NO

Front power LED turn green? >> NO


powers backup after shutdown. >> NO

5volt output on USB ports >> yes

5GHz WiFi works >> yes

Stock IR remote work >> NO

Front power LED turn green? >> NO


powers backup after shutdown. >> YES

5volt output on USB ports >> yes

5GHz WiFi works >> NO

Stock IR remote work >> NO

Front power LED turn green? >> NO


powers backup after shutdown. >> NO

5volt output on USB ports >> yes

5GHz WiFi works >> YES

Stock IR remote work >> NO

Front power LED turn green? >> NO

using the v4, crashes the box (powered off) when trying to ply 4k video. Did not test the other versions.

When each of these versions bootup, the linux code flashes on the left sid of the screen.


Just tried the OS that runs on my HK1 Rbox X4, but the Mecool KM6 Deluxe only goes to the Android recovery screen…

For the remote, download the corresponding remote configuration from the repository (the remote may not be listed by device name, so please compare the pictures) and place it in the root of your SD Card / USB Flash Drive or in ./config once booted.

Ok, I give up… Where is the link that shows the pics?? I see a list with all the boxes, but no pictures to compare. Been years since I last did this, so I am rusty.
This appears to be the correct remote >. remotes/MesonIR/HK1 X3 /

What do I do with these 3 links?? None of them are a downloadable “file”.

No, it´s not your remote
edit: sorry wrong box

No, you are correct, that is NOT my remote… The HK1X3 is my remote.

HK1 X3

How to get the config file?/
I tried to create the remote.conf file, but did not work…

remote.conf (1.4 KB)
I copied this file that I created to the root of the Configfiles folder.
Ok, just learned (I think), that I can’t use the remote.conf file for my remote. I have to use the rc_maps.cfg, So, more reading.
Any help would be appreciaed.

copy KEYMAP file to /storage/.config/rc_keymaps
copy rc_maps.cfg to /storage/.config/

KEYMAP file is in your case the hk1x3 file
The second file is rc_maps.cfg
To download files, right-click on “RAW” => Save as…

There is no “save as”