Report about Amlogic S905X4 HK1 RBOX X4

True, I personally wanted a Shield kinda old, and UGOOS is a brand I respect for supporting their products but was close to the shield’s price. I wanted a decent box with AV1 support, took a chance and went with the HK1 X4. The Tanix X4 is another box I tested (on android) and liked.

In China here you can get a Ugoos X4 directly from the manufacturer (since Ugoos is a China company, and most of CE’s partners also are) with 370 CNY + 13 CNY shipping, that’s only ~56.62USD. Never thought the product will get that much more expensive after exporting…

For me, I buy these cheap boxes for tinkering and development so I can worry less after burning the device (one for only ~200CNY, that’s ~29.6USD), but not for actual usage. I got other more expensive and robust devices for my acutal media and entertaining usage and I would not recommend buying these cheap boxes for your main CE/EE device.

1 Like

I am planning on picking up one of these boxes with the new Amlogic SoC (# VONTAR X98mini Amlogic S905W2 TV Box Android 11 4G 64GB X98 mini Support AV1). Of course, the boxes with the S905W2 are budget SoCs and do NOT support gigabit Ethernet. I think CoreELEC devs are working on this SoC.

Years ago, I tried to find an inexpensive media player that will do it all, guess there is no such animal, but I keep looking. The fun is in the chase. These inexpensive Android boxes running CoreELEC (used to be LibreELEC and OpenELEC), come pretty close to being an all in one media player.

Using Tvheadend server, these devices are a DVR recorder AND player, all in one device, which is accessible anywhere on the local network.

Also, it is amazing that these devices support Netflix in 1080p with DD+ audio (obviously a Netflix subscription is required), and automatic resolution and framerate switching.

Of course these players are my hobby, so I have a lot of them that I have purchased in the last 10 years.

However, if the device you purchase will be your MAIN media player, then, yes, it is better to go with a device that is supported by the CE team. I do think most of the people on this forum are tinkers like me and like messing with new tech. If we destroy a $40 or $50 item, it is much better than destroying a $170 USD device.

To be noted, out of the dozens of boxes that I have tinkered with, in the last 10 years, I have only “bricked” one device that I could NOT recover. About 10 years ago, the Beelink engineers gave some users from Freaktab a box that we helped debug. To swap firmware’s, you had to open the box and short out two pins, they were tiny. Those were the good ole days.

1 Like

S905W2 is S4? so not yet available on CE-19 or CE-20. Only with new (not yet public) 5.4 kernel.

Do CE work onthe tanix x4 ?

Sorry I don’t have a Tanix anymore, and it was only tested on Android.

@josemarprete Thank you for letting us know.

1 Like

I have some good news for all CE users that has a box with JL2101 phy: I’ve ported the JL2101 PHY driver to CE’s kernel, and it works perfectly fine!

CoreELEC:~ # find /usr/lib/modules/4.9.269 -name jl*
CoreELEC:~ # ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc fq_codel qlen 1000
    link/ether 00:e5:00:00:18:c1 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc fq_codel qlen 1000
    link/ether d0:22:be:ea:1a:f1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d222:beff:feea:1af1/64 scope link
       valid_lft forever preferred_lft forever

Backstory: Even I was lucky to get a non-JL2101 HK1 RBOX X4, I was still hit by it as I bought another S905X3 HK1 BOX for tinkering and without any surprise it came with the notorious JL2101.

The driver is not directly available on JLsemi’s website but I managed to find it in the format of patches in embedfire’s LubanCatWrt (an OpenWrt fork) repo for their DoorNet2 for the Rockchip 5.4 kernel they are using. The driver was ported to some other OpenWrt forks as well. After porting the driver and backporting some macros from newer kernels and the driver successfully builds and loads and works with high load for several hours.

I’ll clean up the code a little bit and opened a PR tomorrow to merge this driver into CE’s kernel : )


That’s great news, I was figuring I would have to wait for the 5.4 kernel since I was using the unifreq source and couldn’t get it to load meson8

That will make a lot of people happy…

Did you ever get around to evaluating performance?


I have still been using this X4 device as my primary media player, for CoreELEC only.

There is no noticeable difference between the smoothness of the X4 and X3 boxes that I have, they are both a very smooth and fast when going from screen to screen.

The main thing missing is the dual boot function from within CoreELEC, not sure if it can ever be implemented due to the X4 bootloader.

This box also does not pass through the HDR video codecs at this time.

Bottom line, I would not hesitate to purchase another one of these inexpensive X4 Chinese boxes specifically for CoreELEC.

Not sure if that exactly answered your question.

Hi. You mentioned that the x4 CE doesn’t work with HDR? So only SDR content only?

HDR should work on S905x4 boxes. No idea about clarkss12 issue.

1 Like

HDR works fine on my HK1 Rbox X4S.

What about Dolby Vision? My new TV supports DV

The soc doesn’t support DV, even if it did we still don’t have any breakthrough on DV camp.

Strange, I can not get my TV to show HDR, what settings do I use?

According to the amlogic website the s905x3 and x4 socs support Dolby vision.

Vasco, I ran your code and this is what I got. Problem of my TV not showing HDR. To be noted, I have an X905X3 and the same video shows HDR.
Vasco: “Please run the video and post the output of dispinfo
You can also run dmesg -c and dmesg|paste after pressing play”