Report about Amlogic S905X4 HK1 RBOX X4

I didn’t know that the internal phy was not available thanks. This eth0 interface is not that stable with dropped packets over 50Mbs though using generic phy.

Been testing the ability of this X4 device, and it seems to be very capable. Using the power of CoreELEC, this device can run the Tvheadend DVR server, and the Emby server at the same time.
For testing, I used the $20 USD onn. Android TV 4K UHD Streaming Device (only available in the US). Emby server running under CE, plays everything except LIVE TV. Perhaps I am missing a setting.
Also, most of my media is on external HDDs connected to a miniPC, so I had to mount those drives (what a pain).

Did some boring tests.
You can use a USB network card (RTL8156B, 2.5G) to connect to the network. May be running at 1000M rate.

Hi, I have just joined to ask this question as have almost exactly the same box as the OP. I think possibly the only difference is mine supposedly has Kernel 5.4.125
Android OS Build - RQ3A_210805.001.A1.eng.user.20220525.011422

I specifically went for this box due to the value and features - in hindsight perhaps a step too far in features…

The issue is that the pre loaded KDMC app that appears to be Kodi in a different name is only 18.9 and I want to move to 19.4. I cannot even load the speed tester app from the included repository along with pretty much anything else. I have tried to load Kodi from the official site, ApkPure, Play store and via usb but will only install after deleting the loaded KDMC. So after deleting the installed app it installed but on trying to open it then it simply opens and closes back to the app screen. I can install and use other apps ok.

The seller eventually responded -
“I checked with the factory, the box with the chip s905x4 android 11 now still not working. Have to wait for the app to update again and it will be available.”

So my eventual question is could I use CoreElec latest stable build on my device to access 19.4?
If yes how large a SD card and USB would I need?

Anyone have a working vfd for the HK1 RBox yet?

Please start with hk1-x3-vfd.conf.

Then go here and follow the support instructions.

That way, everyone who owns this device can benefit from a working VFD. Thank you.

1 Like

Gbox23 from Freaktab just posted an updated firmware for this device. Here is the information. Android OS Build - RQ3A_210805.001.A1.eng.user.20220620.224730 release-keys.

I installed it yesterday, uninstalled the KDMC and installed Kodi 19.4 (using the built-in Chrome and getting it from the Kodi website). Had no issues, installing or running Kodi.

CoreELEC does use 19.4, and I would use at least 32Gb micorSD card. Depend on how big your library is, also what apps you will be running. I have used, a 32Gb, 64Gb, and now a 128GB card.
Try to get a fast card if possible, and they are reasonably inexpensive.

Here is the speed test I ran for my cards.

MicroSD speed test.txt (1.8 KB)


Tried it on mine. It does not work.

Then go here and follow the support instructions.

I know how it works. On my other box the x96 max+ VFD is working. The file you posted does not work on my unit. Also see post #209. Another user where the file does not work unfortunately.


Thanks for the Android OTA & IMG update news, I’d to use the toothpick method in order for CE to boot again.


Can the USB ports and Ethernet (not sure if wifi too) be turn-off after CE shutdown?


Strange, I updated to this newer firmware using the USB burning tool, and when I inserted the microSD card with CE, it booted straight into it. Did not have to use the tooth pick method.

I did use the “Reboot to LibreELEC” app from Android, perhaps that replaces the need for the tooth pick.

It doesn’t work on the X4.

I received my HK1 Box X4 with 4GB memory and 64GB storage. I have to say I’m very disappointed with it. My unit have working wifi but Ethernet is not working. Because ethernet doesn’t work I plug in USB ethernet to the USB3 port but found out that it doesn’t work for Networking as it could not connect to the network. The USB3 works with remote control dongle though. When i plug in the USB ethernet to the USB2 port, it works fine.

The worst thing is that this box just crash all the times. When that happen and the screen suddenly display white noise and static noise my speakers. I have to unplug the power source. This happen in both Android and CE. So basically it’ s a faulty hardware and I cannot return.

So my conclusion is that HK1 box quality is really poor and I just wasted $40 on this useless box. Although its cheap but you get a cheapo hardware too. Will not buy another HK1 Box

Do you mean that the box crashes while running Android?? Crashing is not normal anymore on these boxes.

I would do a factory reset, and run it for a while without adding a whole lot of apps. I’m guessing that one of the apps may be causing the crash.

If your box crashes both with Android and CE, I would have to make the assumption that you have a bad power supply

1 Like

Be aware that sometimes in all these TVboxes (HK1 Box X4, HK1 Box S905X3, Vontar X3 etc) the USB sticks, USB ethernet etc may not be fully inserted in the USB port, so there is no good contact and you may assume that the USB port is not working at all or as it should etc. This may happen to any of the 2 USB ports, but it is more common in the angular one…
To find out if you have a bad power supply, you can power your HK1 from its USB port with the firmware cable and the power adapter of your smartphone…If by doing this you do not have any of the problems you talked about previously, then this proves that your power adapter has a problem.

1 Like

The HK1 uses a circular power jack not USB.

I think he meant to use the USB 2 port as the power input port. I have heard that it works, but don’t recall ever trying it.

The VCC in the USB port is wired to the positive contact in the DC port, all +5V on the board are wired together (which is a dangerous design choice as you can fry, say, your expensive external drive you happen to plug on the box, if the power supply is broken).

So connecting the box to a USB power supply with a USB A to A cable will certainly power the box up, and that’s also how the box is normally powered when you use USB Burning Tool to burn an image.

I’d suggest using a better 5V power supply for the sake of your safety and your data if you don’t want to risk frying all things connected on the box altogether when the bundled power supply breaks. I use a 5V 5A power supply from a Cisco switch, and its quality is way much better than the stock power supply

1 Like

Many thanks for posting this.
As it is not really CE related I will respond on the other forum if I have issues when I get round to trying to flash.
Thanks again

1 Like