RTL8723BS bluetooth audio not working on 9.2.5 Amlogic-ng

Hey All,

RTL8723BS broke entirely a while ago in 9.2.2 Amlogic, but was fixed by a now departed dev.

In 9.2.5 Amlogic-ng it works fine (ie keyboard) but BT Audio does not work. I tried doing the pairing manually in bluez but it partially connects and then errors after a while somewhere in the negotiation (perhaps on the audio protocol?). I also tried the latest amlogic-ng nightly, with the same result.

[Harmony Keyboard]# connect A2:02:00:11:5E:4A
Attempting to connect to A2:02:00:11:5E:4A
[CHG] Device A2:02:00:11:5E:4A Connected: yes
[CHG] Device A2:02:00:11:5E:4A UUIDs: 00001101-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device A2:02:00:11:5E:4A ServicesResolved: yes
[CHG] Device A2:02:00:11:5E:4A ServicesResolved: no
[CHG] Device A2:02:00:11:5E:4A Connected: no
Failed to connect: org.bluez.Error.Failed

Let met know what logs would be useful and i’ll be happy to get them. As of yet i’ve not found one that shows the negotiation that occurs at pairing.

Thanks!

I should add that I switched back to amlogic (from amlogic-ng) and it worked no problem.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice