S905X 1GB (Android 6) and CoreELEC NG boot failure

Thank you. Odd thing is I somehow brick the device and it is in recovery now and the USB male/male seems to be detected in the Amlogic USB burning tool (HUB201 Connect success). Select normal erase and erase bootloader as instruction indicated. However, when I tried flashing Aidan img. It failed at 4% Download UBOOT time 23s.

[11:33:29 291][Global][Inf]–Scan end
[11:33:29 338][HUB2-1][Inf]–Open device handle \?\usb#vid_1b8e&pid_c003#5&c1e6cce&0&1#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x00000194
[11:33:29 401][HUB2-1][Inf]–CloneImageProxy
[11:33:29 401][Global][Inf]–OpenImg C:\Users\hieppo\Downloads[v7.5] (UNIVERSAL) Aidan’s ROM [S905X] 1GB 2GB+.img
[11:33:29 401][HUB2-1][Inf]–Connect path=Intel® 82801FB/FBM USB2 Enhanced Host Controller - 265C/P0/P0
[11:33:29 401][HUB2-1][Inf]–Start burning…
[11:33:29 463][HUB2-1][Inf]--------------ERASE BOOTLOADER------------
[11:33:29 573][HUB2-1][Inf]–start SendIdentifyCmd
[11:33:29 588][HUB2-1][Inf]–2-2-0-0
[11:33:29 588][HUB2-1][Inf]-------------Download DDR.USB-----------
[11:33:29 588][HUB2-1][Inf]–2-2-0-0
[11:33:29 588][HUB2-1][Inf]–Control write pll reg1 0xd9000000:0x000000b1
[11:33:30 088][HUB2-1][Inf]–Control write pll reg1 0xd9000000:0x00005183
[11:33:30 588][HUB2-1][Inf]–Control write pll reg1 0xd9000000:0x000000b1
[11:33:31 088][HUB2-1][Inf]–Control write pll reg1 0xd9000000:0x00005183
[11:33:31 588][HUB2-1][Inf]–Write initial succeed
[11:33:31 588][HUB2-1][Inf]–Upload encrypt at 0xc8100228
[11:33:31 588][HUB2-1][Inf]–ulValue = 0xadfc318c
[11:33:31 588][HUB2-1][Inf]–Read encrypt value succeed
[11:33:31 588][HUB2-1][Inf]–Download DDR.USB,size: 49152!
[11:33:31 635][HUB2-1][Inf]–Transfer complete 49152
[11:33:31 635][HUB2-1][Inf]–Run at address 0xd9000000
[11:33:31 651][HUB2-1][Inf]–RunInRam success
[11:33:31 776][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:31 776][HUB2-1][Inf]–CheckFileRunState succeed
[11:33:31 776][HUB2-1][Inf]–runResult:0x 0,paraMagic:0x7856efab
[11:33:31 776][HUB2-1][Inf]–ddrCapacity:0x 400
[11:33:31 776][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:31 776][HUB2-1][Inf]–Get Encrpt ulValue = 0xadfc318c
[11:33:31 776][HUB2-1][Err]–download 1 time!
[11:33:31 776][HUB2-1][Inf]–Download UBOOT.USB buffer at 0x0200c000
[11:33:32 402][HUB2-1][Inf]–Transfer complete
[11:33:32 605][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:32 605][HUB2-1][Inf]–Download DDR.USB buffer at 0xd9000000
[11:33:32 652][HUB2-1][Inf]–Transfer complete
[11:33:32 652][HUB2-1][Inf]–DownCheckPara succeed
[11:33:32 652][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:32 652][HUB2-1][Inf]–RunInAddr at address 0xd9000000
[11:33:32 699][HUB2-1][Inf]–ReadCheckPara succeed
[11:33:32 699][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:32 699][HUB2-1][Inf]–Get Encrpt ulValue = 0xadfc318c
[11:33:32 699][HUB2-1][Inf]–Download DDR.USB buffer at 0xd9000000
[11:33:32 745][HUB2-1][Inf]–Transfer complete
[11:33:32 761][HUB2-1][Inf]–DownRunPara succeed
[11:33:32 761][HUB2-1][Inf]–2-2-0-0-0-1-0-0
[11:33:32 761][HUB2-1][Inf]–RunInRam at address 0xd9000000
[11:33:45 263][HUB2-1][Inf]–Detect Device remove timeout
[11:33:45 263][HUB2-1][Inf]–Device is connected
[11:33:45 263][HUB2-1][Inf]–Close device handle 0x00000194
[11:33:45 326][HUB2-1][Inf]–Open device handle \?\usb#vid_1b8e&pid_c003#5&c1e6cce&0&1#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x00000194
[11:33:53 405][HUB2-1][Inf]–IOCTL_IDENTIFY_HOST_Handler ret=-116 error_msg=libusb0-dll:err [control_msg] sending control message failed, win error: The I/O operation has been aborted because of either a thread exit or an application request.

[11:33:53 405][HUB2-1][Err]–CheckFileRunState failed
[11:33:53 405][HUB2-1][Err]–[0x10303004]Romcode/Switch status/Identify/Error result
[11:33:53 405][HUB2-1][Inf]–Close device handle 0x00000194

Based on the log it seems like my usb cable was removed but it never did.

Which version of the tool are you using?

I am using v2.2.0

I use 2.2.4, but I can’t see that being a huge issue.
Does it always fail at the same point?

Yeah it fail the exact same place. I thought it could be my cable since it is a diy cable. I just solder the two USB type A ends together keep same pin outs. I may need to go out and purchase a manufactured M/M USB type A and try again. I mean the box is toast at the moment. The red LED is solid red and boot nothing at the moment (not internal eMMC or flash card or USB). I guess my only option to debrick this is through M/M USB flash.

ROM may just be incompatible.

After a hairy weekend from trying to flash Aidan’s custom rom as suggested above, I soft bricked my box. Luckily I was able to find my USB UART and see the output. Somehow my box after the fail flashed. It got stuck in a boot loop. So yes, I can theoretically connect M/M and USB Burn Tool detects it but it would not flash any ROM whatsoever. It would always fail at UBOOT about 4%.

I was able to finally resurrect the box using the following method.

If I create a SD card using AML Boot card maker, I was able to boot off the card. It took a while to find a working img to allow it to boot fully into Android. Aidan’s img would not boot fully, I would only see a green screen.

I then adb reboot recovery and I found a Sunvell T95x which was a ZIP format. In recovery, select update from EXT, I was able to select the ZIP file and standard Android flash into eMMC again.

I now can boot from the eMMC. However, this still does not fix my issue with trying to get CoreELEC NG to boot. I guess I still have to find a compatible ZIP to flash.

I am not 100% sure about flashing with USB Burn tool since even after I resurrect the box and tried to flash, it would fail at 4%. USB UART would stop at the error. When I connect to UART again, I will post the output.

@kshi I was not able to successfully flash the your suggested ROM.

@Betatester also has an image that he’s had luck with on S905x boxes. Maybe ask if he’ll share the one he uses?

This is the UART output when trying to boot CoreELEC ng with my current Android 6 firmware/bootloader,
ng.boot.log (108.5 KB)

The firmware I use is for Nexbox A95X-B7N. I can make available if it helps.

1 Like

@hieppo, there you go.

This is from AIdan’s ROM Thread. may be this applies to you
No Reset Button, Connect the box to PC with USB & Connect AC Power WHILE also pressing the Power Button, the device should then connect to the software and Flash

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.