[S905X3] X96Air_P2/P3 4/32GB 1Gbit Lan (How to config)

Yes.
But with this app in a android device


I could access to coreelec (remote location - local network). Only with that app, and I tried mixplorer in android, and the net explorer and total commander in windows

In CE you need to enable SAMBA, ZeroConf and workgroup need to be the same.
In your PC with windows from run try \\coreelec
Verify firewall too

I assigned @ to 24 which is the decoding menu for Kodi. I find that useful. You could change it to 23 for info. Need a better use for skip forward and back.

1 Like

Hi,

you can add/change whatever function/key/keypress you want to whatever button. Your buttons are already mapped in configs, so just choose actions.

In amremote you must assign linux code (for example, 28 for KEY_ENTER - see here), with meson-ir you can just assign direct function (KEY_ENTER).

THX for the great start ! Got my X96Air earlier today and did the config as described herein.

The biggest hurdle I faced was to find the reset button. In all my other devices that is in a small hole. Took me a while to find that in the X96Air it is in the AV port (best to work with a wooden toothpick - well I guess that why it is called toothpick method :slight_smile: )

I did find it more difficult than usual to press in that button for some reason. Glad you sorted it.

I’ve got the X96Air S905X3 box - how long should it take for the Coreelec logo to appear after using the toothpick method?

64GB MicroSD card - using sm1_s905x3_4g_1gbit.dtb device tree

Pretty much straight away. A few seconds at most. Make sure you’re using the generic ng CE.

Something definitely not right then.

Using “dd” on ubuntu to burn the image and using the correct dtb.
Toothpick and “reboot update” method result in a black screen after the X96 logo.

I’ll download the image again and start from scratch

Reset button with SD card doesn’t work (tried 2 different SD cards)
Terminal emulator in Android “reboot update” doesn’t work
Both result in a black screen

Tried “reboot recovery” - nothing
Tried using the update app and adding an empty zip file on the SD card named “test.zip” - that results in Android Recovery starting and giving errors

Any ideas?

Try using this to make your SD card:

https://libreelec.tv/2016/08/usb-sd-creator/

Shoog

Are you 100% sure you’re using the generic image? Apart from that I’m not sure. Maybe try another dtb?

Picture of reset button.
For me i find it easy to press the button and then connect the DC power jack release button after 1 second.

And to be 100% sure I should be using…
CoreELEC-Amlogic-ng.arm-9.2-nightly_20200115-Generic.img.gz

I’ll try the libreelec USB writer, then different dtbs

Yes that’s the right one.

thanks @Rootz for the guide - this made the upgrade from my old m8s pro+ s905x box very easy.

a couple things to note:

4k playback

4K playback using build nighty amlogic-ng 20200115 is very smooth over the gbit network. I did not notice any frame skips even in the 2160p60 HDR Atmos movie that brought my old s905x to its knees.

I am using the kodi default cache value and not the ones recommended in this thread.

using internal storage

switching storage to internal eMMC is quite easy, but only worthwhile when your sd card is slow. I’m using a SanDisk microSDXC UHS-I card and did not notice any relevant differences.

as the internal storage is already a mess with all the android data dirs and all my media content is on a NAS anyway, I switched the storage back to the sd card after a few tests.

# check that /dev/mmcblk1p2 has currently the STORAGE label
blkid
# switch storage to /dev/data
e2label /dev/mmcblk1p2 ""
e2label /dev/data "STORAGE"
# (optional) copy sdcard data to local storage
systemctl stop kodi
mkdir -p /tmp/data
mount -o rw /dev/data /tmp/data
cp -pPR /storage/. /tmp/data
umount /tmp/data
# reboot
reboot

switching back to the sd card as storage is straight forward:

e2label /dev/mmcblk1p2 "STORAGE"
e2label /dev/data ""
reboot

BL301 injection

in the Armlogic-ng nightly builds there is now a menu entry in the CoreELEC settings page that does exactly this. there are also a bunch of options that can be used to configure the remote power on, but the x96air remote does not seem to be among the preconfigured ones.

Well this is irritating. Never had any issues with S905/S905X boxes.

In Android “cat /proc/device-tree/amlogic-dt-id” results in “sm1_ac213_4g”
Tried both 4g dtbs - no luck, also tried 2g dtbs, same result. Black screen.

Tried reflashing the original firmware zip file and that failed. Possibly something wrong with recovery or bootloader?

You need to config “config.ini” with the code of your remote.
Read again the instructions how to…

Do that and begin from scratch.
Your x96air it’s P2 version?

Yes, P2 version. Am I going to have to use the Amlogic USB Burning Tool?
Flashing using a Zip fails.