[S905X3] X96Air_P3

I received this device today and have most recent nightly installed on SD card.

CoreELEC (official): nightly_20200103 (Amlogic-ng.arm)

Wifi 2.4G and 5G both work as does the wired 1Gb/s LAN.

CoreELEC:~ # cat /proc/device-tree/coreelec-dt-id

I cannot get Bluetooth to be seen (it does work in Android) although I get this

CoreELEC:~ # dmesg | grep -i blue
[ 42.964332@2] Bluetooth: Core ver 2.22
[ 42.964339@2] Bluetooth: Starting self testing
[ 42.977399@2] Bluetooth: ECDH test passed in 12747 usecs
[ 42.983168@3] Bluetooth: SMP test passed in 26 usecs
[ 42.983201@3] Bluetooth: Finished self testing
[ 42.983297@3] Bluetooth: HCI device and connection manager initialized
[ 42.983311@3] Bluetooth: HCI socket layer initialized
[ 42.983317@3] Bluetooth: L2CAP socket layer initialized
[ 42.983342@3] Bluetooth: SCO socket layer initialized
[ 43.013005@2] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 43.013012@2] Bluetooth: BNEP filters: protocol multicast
[ 43.013026@2] Bluetooth: BNEP socket layer initialized

CoreELEC:~ # lsmod | grep -i blue
bluetooth 446464 7 bnep

CoreELEC:~ # rfkill list
0: bt-dev: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

I have so far also failed to get the remote or display functioning … I guess I am just not getting the correct files.
Maybe I should generate my own map file?

I realise this is a P3 (apparently the first one posted here) and some hardware might have changed (or not) - who knows?

All suggestions gratefully received.


Apparently the required firmware file for the BT device in the P3 (different to that in the P2) is not yet in the nightly image. Hopefully will be in the future if devs get a chance to look at it.

I generated a temporary keymap file

table mecool, type: NEC

0x119 KEY_BACK
0x111 KEY_HOME
0x116 KEY_UP
0x11a KEY_DOWN
0x151 KEY_LEFT
0x101 KEY_0
0x14e KEY_1
0x10d KEY_2
0x10c KEY_3
0x14a KEY_4
0x109 KEY_5
0x108 KEY_6
0x146 KEY_7
0x105 KEY_8
0x104 KEY_9
0x14c KEY_MENU # Burger button
0x100 KEY_ESC
0x143 KEY_MUTE # Centre top button
0x147 KEY_INFO

1 Like

Display working now using the VFD file for

All good so far. Some tweaks to be made to the remote conf file but nothing drastic.

Set it playing a UHD TV Channel, downscaling to a 1920x1080 monitor for an hour or so and the temp is reading 74C.

There is little or no ventilation in this box which is no doubt a contributing factor.
For the long term I think some ‘adjustments’ will have to be made to allow for air circulation.

1 Like

I have a P3 and the guide for P2 worked for me

I’ve uploaded some remote control files


Display Fix … to get proper colours on display I needed to Enable
CoreElec Configuration - Hardware - Display - 'use_rgb_to_yuv'

To date, the outstanding issues with this box that I recall are:-

Bluetooth … this apparently needs some firmware to enable it. It will likely be attended to when devs get the time.

A/V Audio out … no sound sent to this socket so attachment of an external amplified set of speakers gets no signal from here. This is not exclusive to this device.

The AV from the TV via the HDMI is likely to be of superior quality to the boxes AV socket. The only exception to this I have come across is the excellent DAC built into the S922 (and mostly unavailable via a socket) which the N2 utilizes.


Probably, but the Monitor/TV has a crappy set of speakers so an alternative sink is required to be fed from the A/V socket.

Doesn’t the TV have phono sockets out ? The quality of the Speakers will have no baring on the TV’s phono outs.


The TV audio system borked itself … had been using the 3.5mm socket up to recently.
Not sure about the phono socket as I did not check that.
I replace the X96Air with a Tanix TX3 mini and used the A/V out of that for the TV.
Now the X96Air is being used to feed a monitor. It has crappy ‘tinny’ speakers and needs help badly :slight_smile:

Which or whether, I would expect that the sound should be fed to the A/V socket as with previous devices. I expect it will be attended to as time permits.

Its appropriate to hope but never expect anything with these cheap boxes.
For the longest time the AV socket was simply ignored for support in my experience.


1 Like

I have noticed with Linux over time that it seems to mix up sinks at times - whether due to kernel changes or some other reason I am unsure - but the net effect was that there was no sound on a (previously) default sink until some slight change was made.

For my own case I am happy with the CE situation, but unless such ‘deficiencies’ are reported then it is likely they will not be known or worked on. :wink:

1 Like

What do you mean proper colors?

The colours displayed on screen were not correct … not sure how else to describe it.
That config option is there specifically to correct the problem.

I expect if you want to see the effect yourself you can change that option in your install, reboot, and see if the colours change.

Changing it back to where it is now should fix it again.

I want to know. What different in X96Air S905x3_P3 and X96Air S905x3_P2

WiFi chip seems to be the only practical difference. Its currently not working on the P3

Wifi is working here … I have no idea how well as I do not use it for streaming.
Bluetooth is not yet working.
No sound from A/V 3.5mm socket.

As I do not do UHD, HDR or HQ audio I have no information on those.


My X96 Air 4/32 arrived. Its P3. Guides for P2 are valid for P3 as well.

I didnt bother with finding woodstick for button, I just tried Reboot to LibreELEC_v1.1_apkpure.com.apk and it works very nice.

I am happy to confirm, it boots from USB. I just used back USB port with CE nightly-ng image, + .apk for android there. Boot normally, then install app in stock Android 9, Run it, and then CE from USB booted correctly.

I will buy another USB stick to final setup, as I use my USB just for test I can confirm that in nightly ng 16.1.2020:

  • BL301 injection - works (at least wake up by remote)
  • IR receiver - works
  • VFD works - works
  • Wifi works (2.4 tested) - works
  • LAN works - works
  • 4K content - works
  • Automatic Frame switching - works
  • Boot from USB flashdrive - works, used back USB port and Android .APK method to booting CE
  • Bluetooth - doesnt work

Not tested yet

  • HDR content
  • DVB-T2 driver for MN88973 Panasonic
  • HDMI passthrough DTS(HD)/DD/Atmos
  • included remote - I am using own remote.

From HW perspective, before I plugged in I look into a box, as I was worried about temperature reports here. First thing is, board is upside down (ie. heatsing on the bottom of the box). So I drilled some holes (give some air to Air), and also prepare one bigger, if I would want to add external heatsink (propably I will and put box upside down to 4 stands sticked to the “top”).

After 15minutes 1980/23,976Hz (TV) temperature is around 53°C, with heatsing a bit warm. Thats 17°C more (!!) than I am used to be with Rpi2/C2 in idle, so I maybe I will look around for some piece of allumunium I guess. Hopefully this will be just 905x3 problem, and not some issue within NG… On the 3.14 C2 Ive got 36 in idle, with Rpi2 35 idle.

Pictures for those who are interested:

Did you check if BT is working or what chip it has?

I wrote it in my post… It doesnt… I mean, I just briefly went to the sethings, turn on BT and BT page shows no device found or something like that.