[s922x] UGOOS AM6

Fully working now.
I had to remove the bottom metal case and manually hold in the recovery button for CoreELEC to boot. Seems my AM6 doesn’t have holes for the recovery button on the bottom casing and is solid metal. They must have changed the casing and introduced the recovery markings and hole at a later stage.

Emmm… Am6 has two hole at bottom: recovery and mask rom

I can’t seem to connect to any wifi hotspots.
If I disconnect from my main wifi connection and try to connect to any other wifi hotspots, it just doesn’t connect.
Only way to use wifi is to only have one wifi connection and to restart the device to automatically connect to it on startup, otherwise wifi can’t connect.

Don’t know if it’s a general CoreELEC problem or just with S922x devices with AP6398S wifi?

It’s general… After manual disconnect it doesn’t connect again without reboot.

2 AM6s arrived (1 for me and 1 for a colleague), both rev.A with 1800 Mhz max CPU freq. and firmware version 1.0.

Installation of nightly CE was a breeze, no problems.
This ng-CE seems good, all what I need is working (SPDIF audio, CEC, Gigabit ethernet, HDR10/HLG/HDR10+ test videos play as HDR10), faster than my old S905X and with low temps (39-45 Celsius during playback of audio and video).
This next-gen CE is already stable-enough for me as a daily driver :slight_smile:

I must say: THANK YOU to all the developers and testers who contributed to CE !
Really, maybe you don’t hear this very often these days, but I realize that many hours of your work must have been invested into making all this to work. Please keep up your good work guys :clap:

2 Likes

Hi

I just ordered this (I also have a brand new Odroid N2 4GB) but wanted to compare the WiFi between these and see which one to keep, as I don’t want to use Android I wonder if anyone tried this on this box and got it to work? thanks

ceemmc works on this box.
I use dual boot on this system for test reasons

thank you, about cemmc, do I do it within CoreElec or Windows PC?

All info available in instruction
Answer on your question is in What is needed section
You need to install CE on SD/USB first (within CE)…

I noticed there is two dtb’s for Ugoos AM6, does it matter which one I choose?

You can check in terminal application in Android or CE if you have rev. a or rev. b. Difference is Cores speeds.
cat /proc/cpuinfo | grep Serial
If it starts with 290b then rev.b, if 290a then rev a.
In any case you can start CE with rev.a for both revisions, check via ssh a serial and change dtb to another if required.

thanks, it was 290a, which one is “better”? anyway, I have now booted to latest nightly CE with SD card, what’s next? :slight_smile:

edit: does it take time to boot to start screen? it’s seems to bootloop atm. :slight_smile:

Did you copy g12b_s922x_ugoos_am6_rev_a.dtb to root of sd card and renamed it to dtb.img?
If you have big sd card it will take some time to resize it… but not so much time.
new devices are only a revision… b just have better core speeds.

so I tried with previous nightly and now it worked better, I’m inside CE now. :slight_smile: how do I start the ceemmc tool?

read an instruction fully (hint in the end of it :wink: )

you mean this? :joy:

Any support request for not official supported devices will be ignored.

yes :slight_smile: , but it works for this box

Just out of curiosity; why go for the Ugoos box when the Odroid N2 2gb is just €60 (€65 with the kit)?

yes but I just want to know how to start the tool, I guess using Putty? :slight_smile:


here there is a pdf instruction that includes how to connect…
via Putty ssh for example