[s922x] UGOOS AM6

You can use latest Android image.
Use latest nightly and ugoos dtb. You can start from a revision. After you can change it if you have revision b box.
You need to use terminal application in android and execute reboot update command from there
Or just hold the recovery button, press power button and release recovery button only after you see CE logo

Thank you for the info.
I pulled the trigger yesterday and bought AM6 2/16 model on geekbuying who has distribution warehouse in EU.
According to information available on the web it should be the best device for my needs (optical spdif / cooling / CE / linux / support / BT5). Just hope that CE support will continue for this model :slight_smile:

Thanks, I’ll try and see if it works.
Only pressed Recovery not the power button too and used ‘reboot recovery’, not ‘reboot update’ before.

One word: Perfect :slight_smile:

1 Like

Thank you for ensuring me I didn’t made a mistake with this box :slight_smile:

Hi mo123, could you please also share your experience after you manage to start CE on your box ?
I like the way you described the problem, you seem like a person capable of describe technical details and I value opinions of such persons.

Tried it but it didn’t work.
If I run reboot update from a terminal it puts the device into a bootloop, shows the bootlogo then powers off and on every 5 seconds.
I’ll just have to accept I perhaps have a pre-production unit with different hardware inside, got it when it was first released. Will have to use LibreELEC then and get a USB wifi dongle.

But the strange thing is no dtb file I’ve tried boots, I never even see the CoreELEC logo, just Android.

So I’ve given up hope.

New devices shouldn’t have this problem.

It’s possible you are doing something wrong…
Or may be you need to perform clean install for Android and after to try again
And if it was pre-production then it could be revision a
If after clean Android it still doesn’t work then may be UART logs can help if you could collect them.

Fully working now.
I had to remove the bottom metal case and manually hold in the recovery button for CoreELEC to boot. Seems my AM6 doesn’t have holes for the recovery button on the bottom casing and is solid metal. They must have changed the casing and introduced the recovery markings and hole at a later stage.

Emmm… Am6 has two hole at bottom: recovery and mask rom

I can’t seem to connect to any wifi hotspots.
If I disconnect from my main wifi connection and try to connect to any other wifi hotspots, it just doesn’t connect.
Only way to use wifi is to only have one wifi connection and to restart the device to automatically connect to it on startup, otherwise wifi can’t connect.

Don’t know if it’s a general CoreELEC problem or just with S922x devices with AP6398S wifi?

It’s general… After manual disconnect it doesn’t connect again without reboot.

2 AM6s arrived (1 for me and 1 for a colleague), both rev.A with 1800 Mhz max CPU freq. and firmware version 1.0.

Installation of nightly CE was a breeze, no problems.
This ng-CE seems good, all what I need is working (SPDIF audio, CEC, Gigabit ethernet, HDR10/HLG/HDR10+ test videos play as HDR10), faster than my old S905X and with low temps (39-45 Celsius during playback of audio and video).
This next-gen CE is already stable-enough for me as a daily driver :slight_smile:

I must say: THANK YOU to all the developers and testers who contributed to CE !
Really, maybe you don’t hear this very often these days, but I realize that many hours of your work must have been invested into making all this to work. Please keep up your good work guys :clap:



I just ordered this (I also have a brand new Odroid N2 4GB) but wanted to compare the WiFi between these and see which one to keep, as I don’t want to use Android I wonder if anyone tried this on this box and got it to work? thanks

ceemmc works on this box.
I use dual boot on this system for test reasons

thank you, about cemmc, do I do it within CoreElec or Windows PC?

All info available in instruction
Answer on your question is in What is needed section
You need to install CE on SD/USB first (within CE)…

I noticed there is two dtb’s for Ugoos AM6, does it matter which one I choose?

You can check in terminal application in Android or CE if you have rev. a or rev. b. Difference is Cores speeds.
cat /proc/cpuinfo | grep Serial
If it starts with 290b then rev.b, if 290a then rev a.
In any case you can start CE with rev.a for both revisions, check via ssh a serial and change dtb to another if required.

thanks, it was 290a, which one is “better”? anyway, I have now booted to latest nightly CE with SD card, what’s next? :slight_smile:

edit: does it take time to boot to start screen? it’s seems to bootloop atm. :slight_smile: