[S922X] Ugoos AM6(+)

I have a am6b+ on the way. For interest does it run android tv natively like the Homatics box? Or is it just android OS?

Android 9 (not AndroidTV)

1 Like

Anyone tried to restore a NE backup to a NG CE21 build? I would’ve thought it’s only Kodi settings and addons which would be fairly consistent.

I cannot figure out how to make LEDs on the box to function in a same way they do on Android. It works there like this: red LED for booting the box, green for standby, yellow for working state. in CoreELEC green LED doesn’t work period, and all I see is red LED in all the states. Settings for green LED in CoreELEC section do pretty much nothing. Is this a known issue?

Hey I have a ugoos AM6B+ running latest nightly corelec, and if I don’t turn on player-led I get bad issues with shadows. Turning on player-led remove all problems. This is with a 77 inch LG C2. Any ideas why? Should this not work?

Any of you guys use phillips hue sync box with your setups?

My setup is as follows ugoos am6b+ hooked up to Denon Avr-x6300h which is connected to Phillips Hue sync box which goes to LG G4 oled tv. I’m running the 6/23/24 nightly on the box. When I try playing DV content I get a green picture. Image below.

I noticed that in the hue sync app if I disable Dolby vision enhanced compatibility the picture is normal. But the light sync does not work .

And

I also have a dune hd pro one 8k plus hooked up. It’s connected to the same Denon avr and sync box and tv. Playing the movie on the dune the picture is fine, and light sync works as well with the enhanced setting enabled in the hue sync app.
Picture below

Any idea what could be causing the issues.
I also have a fire cube 2nd gen with CoreELEC and DV setup. Same issue when I tried it as the Am6b+

The first time I play an HDR10/+ on my AM6B+ I get the “green screen” issue. Stopping and starting the playback always fixes it. Very Strange.

Hue sync box isn’t compatible with the tv led option from the am6b+. To match the colours onscreen you have to use player led (lldv). Your dune is using lldv. This defeats the whole purpose of having a proper media player like the am6b+, that is compatible with tv led. If you want the best quality picture, you need to use the tv led option and the hue sync will only have a “fixed” colour. Hopefully Philips releases a new sync box soon, one that actually allows for tv led on Coreelec.

Figured it’d be something like that. Of course I want the best picture quality. That’s why the Am6b and oled tv.
Is it a hardware limitation of the hue sync box that won’t allow it to work with tv led? Or is that something they could address with proper firmware?
If hardware, then I wonder if they have a refresh planned for the sync box. Think the original came out in late 2019.

I’m not totally sure because if I’m not mistaken, the Apple TV also uses tv-led (there’s not even an option to use Player Led) and there’s no issue with the hue light syncing on shows with DV, so my thought is that Coreelec could, somehow, use the tv-led option like Apple TV, meaning, allowing the hue sync to work well with it but the fact is that it doesn’t and there must be so few of us with this setup that it probably will never be addressed.

Apple TV has booth , i use playerled on my PJ and with Ezcoo

Wonder if one of the devs of CoreELEC has the hue sync box. Would be nice to see what they have to say. Was looking to see if there’s a new one in the pipeline, but the information is scarce.

1 Like

According to this video from @DMDreview the Apple TV 4K 2021 and 2023 are Real TV-Led. https://www.youtube.com/watch?v=eQ9SOMlX0AI&t=36s

I’ve got the hue sync,lg oled,marantz avr,it’s 100% The hue sync,don’t kno2 if it’s software or hardware though

fyi, they send me a new one. a week after I posted here and send them a Pic of it. the parcel was undamaged and it needed about 4days!

My AM6b+ finally arrived.

Installed the latest 21.1 Nightly Generic build (via USB Flash drive):

I’m able to boot into CoreELEC, but I’m not seeing the Dolby Vision options under System settings…

I did download and store the dovi.ko driver, and have rebooted a few times.

Going to start over from scratch.

I was able to see that the dovi.ko file was in /flash directory, after booting.

Ran the following command: journalctl -l | grep -i dovi
Received this output:

CoreELEC:/ # journalctl -l | grep -i dovi
Jul 12 22:32:25 CoreELEC kernel: g12 dovi disable in uboot
Jul 12 22:32:31 CoreELEC dovi-loader[3532]: run dovi 'start' for ng
Jul 12 22:32:31 CoreELEC dovi-loader[3532]: loading '/flash/dovi.ko' module
Jul 12 22:32:31 CoreELEC dovi-loader[3617]: filename:       /flash/dovi.ko
Jul 12 22:32:31 CoreELEC dovi-loader[3617]: license:        AML
Jul 12 22:32:31 CoreELEC dovi-loader[3617]: description:    Amlogic Dolby Vision Driver
Jul 12 22:32:31 CoreELEC dovi-loader[3617]: depends:
Jul 12 22:32:31 CoreELEC dovi-loader[3617]: vermagic:       4.9.y SMP preempt mod_unload modversions aarch64
Jul 12 22:32:31 CoreELEC kernel: dovi: disagrees about version of symbol module_layout
Jul 12 22:32:31 CoreELEC kernel: dovi: module license 'AML' taints kernel.
Jul 12 22:32:31 CoreELEC kernel: dovi: disagrees about version of symbol register_dv_functions

Anyone have an idea for where I may have went wrong?

That’s not right build. No DV in CE 22.0, the dovi.ko file that works is for the older linux kernel (CE 21)

Use this generic image:

https://relkai.coreelec.org/?dir=Amlogic-ng/ce-21

1 Like

Sorry about that, pasted the wrong build. Thanks for catching that!
I actually did use 21.1.

Edited above post to reflect correct build.

Does the device need to be connected to a DV capable TV in order to display the options?

Currently just have it hooked up to a 2k non-HDR monitor for installation purposes…

Yes that’s right. DV options only show if display is capable of supporting (detected via EDID)

1 Like