Slight Playback Stutter


#1

I’ve noticed a slight stutter every few seconds, specifically on scenes with motion. As a new user, I’m not allowed to upload attachments. Is there any additional information I can provide to help assist with this?

I’m running this on a Khadas Vim2.


#2

Did you activate the “adjust refresh rate” setting in “Settings > Player > Videos”?


#3

Yes. That setting is set to “Always”.


#4

Your post is very vague and we need more information.

Settings>System>Logging
enable debug logging and component-specific logging
specify component specific logging and enable verbose logging for audio and video

Play your video for a minute or so and then upload your kodi.log to pastebin and provide a link here :slight_smile:


#5

I hate this Kodi setting “adjust refresh rate”! For Amlogic only option “on start/stop” is correct. Setting always can cause this stuttering.


#6

I saw some partial(some regions within the image) picture stutter in livetv as well. It is visible mostly while the screen moves. I’m not sure but I would say it started with 8.95.5.

It is not always there. It appears after some time and is gone again after a restart. I will try to reproduce and log it.


#7

Have the same issue on my Tanix TX9 pro. I though that it was solved (i don’t know how) but yesterday i watched a bluray1080p (sd card) and i feel the same little freeze during the movie. Not every time. Theses freeze appears clearly during scene with landscap with movement like train on the nature.

No idea where the issue come from. I have also added adjust refresh rate on start/stop.

I have this issue on android OS. I tried Coreelec in order to solve it but seems the same :frowning:

No Issue with VLC on my laptop.


#8

Do you happen to be using subtitles? Try turning off the subtitles and see if it stutters. Theres a known issue on some devices where it stutters whenever a subtitles shows.

For me, the fix is to create an advancedsettings.xml file under userdata with this :

<advancedsettings>
<gui>
    <algorithmdirtyregions>0</algorithmdirtyregions>
  </gui>
</advancedsettings> 

It does increase the temperatures a bit, but fixes the problem.


#9

I wasn’t using substitlle yesterday…


#10

Come on guys you must all know by now we can’t help you if you don’t help us by providing adequate logs or samples.


#11

Sorry, i’m a noob… I will provide you the log as soon as possible.


#12

Hi, please find here the log playing video with stutter.

https://paste.kodi.tv/ijomiradef


#13

Looks like you are trying to playback 24hz content at 60hz. This will lead to microjudder if your display doesn’t handle the reverse 3:2 pulldown.


#14

What does it means. TV setting issue ? is there something I need to check on TV setting.
However, i try to play the video by using a usb stick and playing it with the tv player and it works.


#15

Please follow this guide and see if it fixes the problem.