Slight Playback Stutter


#9

I wasn’t using substitlle yesterday…


#10

Come on guys you must all know by now we can’t help you if you don’t help us by providing adequate logs or samples.


#11

Sorry, i’m a noob… I will provide you the log as soon as possible.


#12

Hi, please find here the log playing video with stutter.

https://paste.kodi.tv/ijomiradef


#13

Looks like you are trying to playback 24hz content at 60hz. This will lead to microjudder if your display doesn’t handle the reverse 3:2 pulldown.


#14

What does it means. TV setting issue ? is there something I need to check on TV setting.
However, i try to play the video by using a usb stick and playing it with the tv player and it works.


#15

Please follow this guide and see if it fixes the problem.


#16

I try the CoreElec new version with Kodi 18.0 and you are right concerning the stuttering. It seams coming from the subtitles. I try to add the " advancedsettings.xml" in Userdata but its the same unfortunetely. :frowning:


#17

i found this subject which can probably help but its about libreelec. I don’t know to use this on coreelec.


#18

Please don’t expect us to read 17 pages to find a possible solution.
I jumped directly to the last page and in the last posts the users are still complaining about stuttering video playback with subtitles.
So I don’t think a real solution was found.

But with the last CE version and dirty regions switched off, a lot of users reported success.


#19

In fact, in the first post there is a link to the solution… It’s about overclocking GPU.


#20

Yep, and later on in this discussion they are talking about disabling dirty regions as a better option.


#21

On my side, i don’t know why but it’s not working. I tried also to add the Smartdraw line.

On the debug after opening advancedsetting.xml, there is the warning “CSettingsManager: missing version attribute”. Maybe I did something wrong when i add the xml file.

debug log : https://paste.kodi.tv/abukasapup


#22

On my side I would like to add that I’m also experiencing micro stuttering when watching any kind of content (h264, h265) on my Odroid-C2 with CoreELEC latest 8.99.2 build. once I have installed CE on the box I did customization manually so there are no leftovers dragged from .kszaq’s release (https://kszaq.libreelec.tv/s905/8.2/8.2.3.1/) that I use previously. And the most important information is that in kszaq’s build there are no micro stuttering at all, just zero, null.

I have all recommended settings:

  • no whitelisted resolutions, GUI resolution set to 1920x1080p / 50 Hz, Adjust display refresh rate set to “on start / stop”, Sync playback to display is “Off”
  • in advancedsettings.xml added section: algorithmdirtyregions 0 algorithmdirtyregions
    and still while watching a movie time to time (once per every around 15 - 20 minutes) there is micro stuttering noticeable.
    I have collected kodi.log with “FFmpeg libraries”, “Audio component”, “Video component”, “audio/video timing information”, “Database component” enabled and I see the following entries when micro stuttering occurred:

20:28:24.308 T:3577291632 DEBUG: CVideoPlayer::ProcessVideoData size:2989 dts:1810.058 pts:1810.058 dur:41.000ms, clock:1799.766 level:130
20:28:24.309 T:4064641904 DEBUG: ActiveAE::SyncStream - delay frames:61440 error 2314ms
20:28:24.309 T:4064641904 DEBUG: ActiveAE::SyncStream - delay frames:61440 error 2282ms
20:28:24.310 T:4064641904 DEBUG: ActiveAE::SyncStream - delay frames:61440 error 2250ms
20:28:24.316 T:3485094768 DEBUG: CAMLCodec::DequeueBuffer waited:8.109ms m_rel:0
20:28:24.317 T:3485094768 DEBUG: CAMLCodec::GetTimeSize: len:40 dl:119301 fs:110519 front:1561
20:28:24.326 T:3485094768 DEBUG: CAMLCodec::DequeueBuffer waited:8.112ms m_rel:0
20:28:24.327 T:3485094768 DEBUG: CAMLCodec::GetTimeSize: len:40 dl:119301 fs:110519 front:1561
20:28:24.330 T:4086993696 DEBUG: CAMLCodec::PollFrame elapsed:35.322ms
20:28:24.336 T:4086993696 DEBUG: PrepareNextRender: frameOnScreen: 1799.793 renderPts: 1799.820 nextFramePts: 1799.798 -> diff: 0.022 render: 1 forceNext: 0

Media info of the movie I was watching is:
Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main@L4@Main
Codec ID : V_MPEGH/ISO/HEVC
Duration : 45 min 42 s
Bit rate : 1 087 kb/s
Width : 1 920 pixels
Height : 960 pixels
Display aspect ratio : 2.000
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.025
Stream size : 355 MiB (74%)
Language : English
Default : Yes
Forced : No

No subtitles muxed nor in external srt file but to be honest micro stuttering is much rarely happening since I have added algorithmdirtyregions 0 algorithmdirtyregions section.

File created is almost 30 MB so if you need whole log let me know how I can deliver it to you.

I’m looking forward to be helpful for you guys in troubleshooting this micro stuttering issue.


#23

Pushing your device past it’s hardware’s designed operating parameters to make it work isn’t a real solution (at best, a workaround) :roll_eyes:


#24

Still trying to get more information.
These are the kodi.log lines when micro stuttering occurred and was noticeable visible at 11:22:02, 11:26:41 and 11:27:01:

11:22:02.553 T:3587920752 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:24594.283242, adjusted:41708.333333
11:22:02.553 T:3587920752 DEBUG: CVideoPlayerAudio:: sync error correctiom:0.042
11:26:41.084 T:3587920752 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-27192.769468, adjusted:-41708.333333
11:26:41.085 T:3587920752 DEBUG: CVideoPlayerAudio:: sync error correctiom:-0.042
11:27:01.563 T:3587920752 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:23139.716492, adjusted:41708.333333
11:27:01.563 T:3587920752 DEBUG: CVideoPlayerAudio:: sync error correctiom:0.042


split this topic #25

A post was split to a new message: Post deleted. Please familiarise yourself with Forum Etiquette


#26

We have already fixed seeking in the next version but thanks for the insulting comments :+1:.


split this topic #27

A post was split to a new message: Post Deleted. Please familiarise yourself with Forum Etiquette before posting


#28

I solved my issue. I fact the advancedsetting file (dirty region) is working. the video stutter only the first time subtitles appears. After that there is no more stutter.
Hope that this reply will help people who have the same issue.

Thanks to the CoreElec team. You gave me the solution before and I didn’t realise that the stutter occure only one time