[SOLVED] Bluetooth not working

Yes 20190928 nightly image fix problem in mecool k2 s905d

1 Like

Unfortunately, still not working on my Mecool KM9 Pro (20190928 nightly)
CoreELEC-KM9PRO:~ # hciconfig -a
hci0: Type: Primary Bus: UART
BD Address: 8C:F7:10:E7:F7:DF ACL MTU: 1021:8 SCO MTU: 64:1
DOWN
RX bytes:595 acl:0 sco:0 events:29 errors:0
TX bytes:387 acl:0 sco:0 commands:29 errors:0
Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH SNIFF
Link mode: SLAVE ACCEPT

Solved with nightly! Thanks! :ok_hand:

1 Like

can u share the file nightly image because i can download it(slow)

don’t worry with file, i got it.

my k3 pro bluetooth fixed. thank to team

1 Like

And what about these problems? Has it been solved too?

Yes nightly image fixed problem in KII - Pro
Many thx to the team !

Is the script still necessary for auto connect?

It is not necessary to do anything.

  1. If you have executed any previous command to try to fix bluetooth, then check that in the /storage/.config/system.d directory there is nothing related to bluetooth. If you find something related to bluetooth or brcmxxxx, delete it. Also check that in the file /storage/.config/autostart.sh there is also no bluetooth or brcmxxxx line command. Then restart CoreELEC. (Clean restart without BT patches).

  2. Check that your CoreELEC version is nightly 20190928 or higher. If this is not the case, update CoreELEC to the latest nightly version.

  3. Turn on bluetooth and pair your headphones in Settings. Bluetooth already works!

  4. For the sound to go to your headphones it is necessary to select Settings->System->Sound->Audio_Device to ‘Bluetooth_Audio’. (This is the manual mode).

  5. If you want to transfer the audio to your headphones automatically, it is necessary to install the ‘Bluetooth Audio Device Changer’ Addon.

1 Like

is the 5) working for you? It had never been working with MeCool KIII that I’m talking about the script before.

Yes, ‘Bluetooth Audio Device Changer’ addon works. Check in addon settings that Audio Device = ALSA:default

I don’t understand you when you use the word ‘script’, what script do you mean?

1 Like

This script.
It had been necessary to auto switch to bluetooth after bluetooth is connected before 9.2 version. And how to set it up to connect my phones automatically? Of course the headphones are not cheap and works with everything automatically but not with CE Mecool KIII. What should I set in the addon config?

Sorry, I don’t know this script. The CoreELEC Team addon works well for me, but you are right that in the previous versions it was not so. I use headphones very little and when I do, it is in other TV Box clients of CoreELEC, which work on android.

Unfortunately, BT in Tanix TX3 Max (RTL8823BS) does not work even with the latest nightly build

@Toyman I have the same Box and you’re right, I think they are trying to solve. See this posts:


Any chance for a fix for the AP6212 chip? Was working before the official 9.2.0 release (tried latest nightly & CEC fix develop build of today).

Yes, I’ve seen your post but I thought the issue is solved as 9.2.0 announcement states that it “fixed RTL8723BS bluetooth support”

This thread is for BCM4335 and has been solved, please don’t hijack, open a new thread.