(Solved but Confused still) Hard system crashes consistently every 20 minutes since yesterday

My system crashes to the coreelec logo (hard crash) every 20 minutes consistently. Is there a way to determine why my n2 hard crashed? I have seen soft crashes where kodi re-initializes, but never these hard crashes before.

Is there a crash log I can view?

When I try to view the crash log in kodi log uploader, it simply says there is no crash log.

(Using N2 + latest nightly)

Any help would be appreciated

Thanks guys!

EDIT :slight_smile:

So I found out what was causing the issue. I unplugged my microsd and the issue stopped. It had been working beautifully and still does on my windows pc. What might the reason be for this? I run off my emmc.

EdiT 2 : so that was not the issue afterall! The issue has to do with Smb! I discovered this after many hours of testing.

In summary : copying a large file over Smb from my windows pc causes these hard crash / restarts every 20-30m – let’s say if the copy takes an hour, itl for sure restart crash. When I’m not copying any file, it doesn’t crash. Iv tried with multiple drives (USB / micro sd) and the problem persists - I can leave and access any drive locally on the device without issue)

Maybe SD has gone bad? it does happen, Sandisk Ultra cards are the worst for it.

Thats what I have. It’s only been used for two weeks.

The thing is, it seems to be working on windows, despite everything. I can copy files off of it. Just Smb ing into the microsd from Windows and copying caused crashes of coreelec not just kodi.

Weird things happen with some uSD cards. I have one “Sandisk Ultra HC I 32GB” that works perfect on Windows PC and on Odroid N2, but is completely unusable on Mecool KM8. On KM8 writing to this uSD is impossible without lots of errors, and occasional crushes of the box are unavoidable.

Check with another sdcard. On my LePotato board the micro sd slot has gone bad just after about 10 insertion-removal cycles. Maybe the same issue here.

So after many hours of testing, it’s not the actual SD card.

It has to do with Smb.

Basically, copying a large file over Smb from my windows pc causes these hiccup restarts every 20-30m – let’s say if the copy takes an hour, itl for sure restart crash. When I’m not copying any file, it doesn’t crash. Iv tried with multiple drives (USB / micro sd) and the problem persists.

Is there any way to dig deeper into the issue?

Thanks guys