[SOLVED] Cannot access NFS share on Odroid N2


I have three machines, (main pc), (media server), (odroid n2 coreelec).

I have a nfs share on my media server and on my main pc. I can see and mount the nfs share from the media server on my main pc.
But I cannot see the share from the media server in CoreElec, I CAN see the share from my main pc alright but nothing else.

I also have a Vero4k that I have used up until now, where i could see the share from the media server no problem.

I have no idea where my mistake is. Maybe someone here has an idea?


Try to add the NFS share manually.

Doesn’t work either.

So… interesting thing. I tried kodi on my main machine, and it doesn’t see the network share either, even though I have it mounted through fstab on the same machine. When I try to add it manually it says that it couldn’t connect to the server.

Tried mounting the folder manually in bash, but couldn’t access the folder afterwards.
Added no_root_squash to export options on server.

Kodi still won’t discover it, but I’m able to set it manually now. Good enough for me.