[SOLVED] H96 max x3 - supported device?

I buy this box but i dont see him in supported device, will be added? (9.2.2)

I try generic device for S905X3 but controller doesnt work. I need original controller for box

next, sisplay on box is turn off (it is possible turn him on coreelec)

I must waiting for new coreelec version? When box will be fully supported?

Which version of coreelec i must use? And which file from device tree for boot?

Many thanks for help

(Im sorry for my weak and easy english)

1 Like

Did it boot up to CE?

if the remote is not working, read the guide about how to get it working.

H93 Max X3 works under CE.

I used the generic X3 dtb matching my 4/64GB device: sm1_s905x3_4g_1gbit.dtb - don’t forget to rename to dtb.img.

For display, follow : How to configure VFD

Use the vfd.conf for HK1 (X3) !

For remote, use this: H96max_X3_meson.zip (642 Bytes)

Unzip and copy the files “X92_remote” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/

For Bl301 injections, use this file config.ini (5.6 KB) according to instrucftions in CoreELEC BL301 Wake-Up feature [inject_bl301]

I got the following values: Received IRMP code: remotewakeup=‘0x7e817f80’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’

The above should take care of getting a fully working H96 Max X3.


Hello, I have H96 Max X3, but display not work - I tried also HK1 X3.

Where i find this path?
/storage/.config/rc_keymaps/ and “rc_maps.cfg

and what is BL301 injections?

I use coreftp lite to log in to the device

or from windows explorer \\ipaddress\storage\configfiles\ rc_keymaps

BL301 injections are to enable turning the device on with the remote.

Try searching the forum

1 Like

I just bought this model of tv box, if you need any help for a complete integration, I can help you. When I receive it, I will start it up using the generic + remote control.

When I first downloaded the VFD file from github I did it wong (dl’ed the html site rather than the file) mayeb same happened to you ? Try this one : vfd.conf (1.2 KB)


Status not at this moment:

Install and boot CoreElec - Woring
Remote - Working
Display - Working

Remote Wake UP - dont working, i dont know ho i can apply BL301 injections, its looking hard :confused:

I dont understand at this manual:

i dowlonoad PUTTY for Windows:
Join to device and root
type: inject_bl301 and sync && reboot

what now with config.ini?? Where i put him?

it is on the uSD card:

The easiest way is to insert your eMMC/SD card to a PC and edit the values remotewakeup , decode_type and remotewakeupmask in the config.ini file by a unix compatible file editor.

path? i cand find them

Better use SSH to edit this file

i have no flash folder :frowning:

mount -o remount,rw /flash

after which you you can then edit the config.ini file

nano /flash/config.ini

1 Like
CoreELEC:~ # mount -o remount
devtmpfs on /dev type devtmpfs (rw,relatime,size=1958708k,nr_inodes=489677,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
/dev/mmcblk1p1 on /flash type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on / type squashfs (ro,relatime)
/dev/mmcblk1p2 on /storage type ext4 (rw,noatime,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/debug type cgroup (rw,nosuid,nodev,noexec,relatime,debug)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /var type tmpfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
CoreELEC:~ # rw /flash
-sh: rw: not found
CoreELEC:~ #
CoreELEC (official): 9.2.2 (Amlogic-ng.arm)
CoreELEC:~ # inject_bl301
Starting bootloader blob BL301 injection tool...

This tool can be used to update the bootloader
blob BL301 of the vendor bootloader on the internal
eMMC. This bootloader blob BL301 is customized by
Team CoreELEC to support all wake-up features like
CEC, Wake-On-LAN, IR, and GPIO wake-up from
suspend or power off state!

Device serial number: 2b0c100001172a000006363043575050
Using CPU type SM1 (2b): S905X3, S905D3
Using binary type because of CoreELEC DT-ID: Generic
Using /dev/bootloader as bootloader partition

Testing bootloader for package version v2...
Did not find Amlogic image v2 header magic!

Searching TOC_HEADER. Please wait...
Found TOC_HEADER at:            0x00010210
Name:                           AA640001
Serial Number:                  12345678
Flags:                          0

UUID:                           9766FD3D89BEE849AE5D78A140608213
Offset Address:                 0x68000 (absolute: 0x78210)
Size:                           0xE570
Flags:                          0x0
Found BL30 blob image at:       0x00078210
Amlogic magic:                  @AML
Old signature:                  7946BB29DFAE99110347FCB892629584B6BECCFB26CF51F0                14D394A39ADC6ED0
Using BL301.bin:                Generic_2b_bl301.bin
Use config.ini value:           usbpower = 0x01
Use config.ini value:           wol = 0x01
Use config.ini value:           remotewakeup = 0x23dc4db2
Use config.ini value:           decode_type = 0x00
Use config.ini value:           remotewakeupmask = 0xffffffff
New signature:                  7946BB29DFAE99110347FCB892629584B6BECCFB26CF51F0                14D394A39ADC6ED0
Update of BL301.bin on eMMC is not needed, exit now...

I think i do everything at on: CoreELEC BL301 Wake-Up feature [inject_bl301]

but i missing something :confused:

You can’t split the mount command kostaman posted into 2 separate lines. Make sure you copy and paste it as a single command.