[SOLVED] HDMI Audio - Can it be muted/disabled?

My TV will display a small bright red box in the bottom left corner showing a mute symbol and text, this stays on screen the entire time the TV is muted - not something I enjoy looking at when viewing. At the moment I’m turning the volume down to zero instead of muting.

The reason I’m doing any of this is because the encoded source audio is being sent to the HDMI channel when S/PDIF passthrough is active, so I’m getting the properly decoded audio via my AVR while having to listen to the bitstream noise through the TV.

Are you able to set the TV so the audio out is the Optical Output rather then the TV speakers? If so, that will mute the TV.

Yes, I can change the TV settings to stop audio output through the speakers, but this is really no different to turning down the volume. It’s also more involved as you have to go through a number of menus to make the change.

I still use my TV as a TV, so anything that allows me to configure the N2 to stop HDMI audio output is the ideal solution. Given that this was a previous software configuration option, I’m curious to find out if it’s been removed entirely, or whether it’s still there and the interface to configure it has been overlooked with the newer releases.

Sorry to hear you’re out of luck then, it does exist on my default latest stable 9.0.3 installation.

All good. Appreciate you taking the time to reply.

At least I know it did exist in the past. :smiley:

Ok, now that I understand what the problem is, and why you want this. ssh into your N2 and use the following command, to mute the audio on the hdmi.

amixer sset 'Audio hdmi-out mute' on

If this has the desired effect for you I can add it as a setting in the gui.

edit: just so you are not questioning your memory. It’s the older devices(s905/s912) that has the option in the gui to mute the hdmi audio. This was probably removed for the newer devices because the way it was done on the older devices doesn’t work for the newer devices(s922x/s905x2/a311d).

1 Like

Many thanks for that cdu13a.

I’ve tried it and can confirm that it works as desired. I can now enjoy all audio output via S/PDIF without having to turn down the TV volume.

Really appreciate you taking the time to rectify this. :+1:

It may help the issue I’m having too in regards to hdmi audio that I posted about some weeks ago but got no responses on.
I’m using an analog receiver for audio, and HMDI audio is leaking in in the form of distorted audio with noisy hiss. The workaround I’m currently doing is enabling HDMI audio instead of analog and then switching again back to analog. I have to do that every time CE is rebooted to install nightlies.

Adding a HDMI mute option would definitely be welcome!

I don’t understand anything about what you say. As @Rascal said, this option is available in CoreELEC 9.2.0

I don’t have it on current nightly. Rascal said he has it on 9.0.3 not on 9.2.0. Didn’t try on the default skin but I’m using confulence not something custom.

Lots of confusion! To clarify I’m running 9.0.3 official version and the option to disable HDMI audio is not in ‘Settings/System/CoreELEC’ or anywhere else. Can anyone other than cubimol confirm it’s in 9.2.0?

Just a wild guess but maybe it only exists on the non-ng build. I have S912 soc and it’s there on the official 9.0.3 version.

And I have the odroid N2 4gb, running 9.0.3 from a 8gb eMMC with standard Estuary skin. Seems your the lucky one. (Just checked 9.20 stable and 20191010 nightly and its not in either so hopefully cdu13a will include it).

These options are only available on devices with kernel 3.14, currently not available on ng (4.19 kernel) devices.

Has this been re-added to CE?

Don’t think it was added.
I tried with the command suggested and I get:

CoreELEC:~ # amixer sset 'Audio hdmi-out mute' on
Simple mixer control 'Audio hdmi-out mute',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

Is that what it’s supposed to say?

1 Like

@timfolk Sorry for the delayed response. I’ve not had much free time lately.

I just looked and, that is the output I get from that command. The on and off might be reversed from what you might expect because it’s not in referring to audio being on or off but if the mute is on or off.

Given that the subject is audio, I guess the more important question is does that mute the hdmi audio for you? If that doesn’t mute the HDMI Audio, can you let me know which build and device you use so I can look into it.

The Amlogic-ng builds don’t have mute HDMI Audio as a menu option yet. Will try to add it as a menu option soon.

cdu13a My issue is different from the OPs, but was thinking it could solve mine too. I use an old analog 2.0 receiver and I get hissy sound leaking from HDMI. The workaround is starting a video, switching to HDMI in system-audio and then back to PCM. That keeps the leaking audio away till the next time I restart CE.
I tried the command today before updating to latest nightly. After nightly was updated and CE restarted, the hdmi leak was there.
I’m on Odroid N2 and Nightly 01/11.
btw, the op reported it worked for his issue.

Just downloaded the latest nightly build and tried it out. Sound is still being output simultaneously on the HDMI and S/PDIF channels but the output on the HDMI channel is now being decoded, so no more “fuzzy” noise of the bit stream.

Still looking forward to the mute HDMI channel option being re-added to the CoreELEC settings.