[SOLVED] HDMI Audio - Can it be muted/disabled?

Lots of confusion! To clarify I’m running 9.0.3 official version and the option to disable HDMI audio is not in ‘Settings/System/CoreELEC’ or anywhere else. Can anyone other than cubimol confirm it’s in 9.2.0?

Just a wild guess but maybe it only exists on the non-ng build. I have S912 soc and it’s there on the official 9.0.3 version.

And I have the odroid N2 4gb, running 9.0.3 from a 8gb eMMC with standard Estuary skin. Seems your the lucky one. (Just checked 9.20 stable and 20191010 nightly and its not in either so hopefully cdu13a will include it).

These options are only available on devices with kernel 3.14, currently not available on ng (4.19 kernel) devices.

Has this been re-added to CE?

Don’t think it was added.
I tried with the command suggested and I get:

CoreELEC:~ # amixer sset 'Audio hdmi-out mute' on
Simple mixer control 'Audio hdmi-out mute',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

Is that what it’s supposed to say?

1 Like

@timfolk Sorry for the delayed response. I’ve not had much free time lately.

I just looked and, that is the output I get from that command. The on and off might be reversed from what you might expect because it’s not in referring to audio being on or off but if the mute is on or off.

Given that the subject is audio, I guess the more important question is does that mute the hdmi audio for you? If that doesn’t mute the HDMI Audio, can you let me know which build and device you use so I can look into it.

The Amlogic-ng builds don’t have mute HDMI Audio as a menu option yet. Will try to add it as a menu option soon.

cdu13a My issue is different from the OPs, but was thinking it could solve mine too. I use an old analog 2.0 receiver and I get hissy sound leaking from HDMI. The workaround is starting a video, switching to HDMI in system-audio and then back to PCM. That keeps the leaking audio away till the next time I restart CE.
I tried the command today before updating to latest nightly. After nightly was updated and CE restarted, the hdmi leak was there.
I’m on Odroid N2 and Nightly 01/11.
btw, the op reported it worked for his issue.

Just downloaded the latest nightly build and tried it out. Sound is still being output simultaneously on the HDMI and S/PDIF channels but the output on the HDMI channel is now being decoded, so no more “fuzzy” noise of the bit stream.

Still looking forward to the mute HDMI channel option being re-added to the CoreELEC settings.

Magic, I needed advice earlier and can now offer it.
I was in the same situation with my older TV and avr.
Any good with a soldering iron? You need a 3.5mm plug with a couple of resistor’s, one soldered from left to ground, the other soldered right to ground.
This makes the TV think it has headphones plugged in so mutes its internal speakers.
Avr gives you your sound.

Works on older TV’s, but newer models, like lots of phones these days, do not have 3.5mm headphone sockets. BT seems to be the in thing!

Hi cdu13a,

Apologies for reactivating a reasonably old post, but I’m new to N2’s, and CE and I am struggling with this issue of preventing HDMI audio and 3.5mm jack audio being sent simultaneously. I’d like others, I’d like to prevent HDMI audio being sent as I use the DAC 3.5mm for audio out.

There is no “Disable HDMI audio output” option as others have noted, but " amixer sset ‘Audio hdmi-out mute’ on" works, and is persistent over CE restarts, but not over N2 reboots.

So a “Disable HDMI audio output” option in settings would seem to be ideal.

I’ve hunted through the forum, but cannot find any mention of this finding its way into a stable release, and all discussion seems to have ended some time ago.

Have I missed something? Is it still on the “to do list”, or has it been abandoned?

Many Thanks.


CoreELEC (official): 9.2.3 (Amlogic-ng.arm)

When you select the PCM audio device, you should only get audio from the 3.5mm output, and nothing from HDMI.

Hi TheCoolest,

Thanks for your response.

I’ve just double checked everything, I’m definitely getting audio from both the 3.5mm jack and the HDMI with either of the PCM audio devices selected in CE:

alsa:default (aml-augesound analogue), pcm
alsa: aml-augesound, pcm

I also reconfirmed that running “amixer sset ‘Audio hdmi-out mute’ on” does correctly suppress HDMI audio, and although persistent through CE restarts, it does not survive a full N2 reboot, and needs to be run again to suppress HDMI audio with either PCM audio device selected.

Many Thanks,


Put your command to .config/autostart.sh

1 Like

All OK now. Thanks very much for your assistance.
The only question I have now is: Why didn’t I think of that? D’ Oh! :worried:
Tnx Again,

1 Like