[SOLVED] HLG HDR output flagged as HDR10 PQ

OK - looks like I may have to look at my HD Fury Vertex… Taking that out of the path - but with the TV and AVR still in circuit - my TV flips into HLG HDR mode (not HDR10 with a conversion) when I play an HLG file.

I think we can mark this thread as solved. Sorry for wasting everyone’s time.

Here is my dispinfo without the HD Fury Vertex in circuit in GUI mode : http://ix.io/21qq

------------ /sys/devices/virtual/amhdmitx/amhdmitx0/hdr_cap ------------
HDR Static Metadata:
    Supported EOTF:
        Traditional SDR: 1
        Traditional HDR: 0
        SMPTE ST 2084: 1
        Hybrif Log-Gamma: 1
    Supported SMD type1: 1
    Luminance Data
        Max: 0
        Avg: 0
        Min: 0

HDR Dynamic Metadata:

colorimetry_data: df

and here is dispinfo when playing an HLG file


My bad. Very sorry everyone.

“BAD HD Fury. BAD…” The irony that the thing that provides me with the most data is proving problematic. It has worked properly in the past (and shown devices like the Rock Pro 64, the Amazon Fire TV Stick 4K etc. outputting HLG) - I think it must have got stuck in an odd mode.

On the plus side - it does look as if CE on the N2 does a good attempt at an HLG->HDR10 EOTF conversion.

Now we just need the www iPlayer add on to support UHD HDR on-demand and not just the live streams.

I have the same issue. I’m running @cdu13a’s Ng build on Le Potato. When playing a HLG sample the TV switches to “ST.2084” mode instead of “HLG”.

When I run “echo 1 > /sys/module/am_vecm/parameters/force_pure_hlg” and play the HLG file - the tv would correctly switch to HLG mode.

For now I added the above command to autostart.sh as it does not seem to affect HDR10 videos - with HDR10 the TV still switch to ST.2084.


Make sure that HDR to SDR is set to Auto and SDR to HDR is set to Off.

Tone map settings don’t make any difference, the TV still switch to ST.2084.

My bad. TV does indeed switch to HLG when “HDR to SDR” is set to Auto.

Hmm…, ??? :wink:

1 Like

In CoreELEC settings.

He meant that you said “HDR to SDR” twice :grinning:

d’oh, thx. I fixed it.