[SOLVED] How to find legacy DTBs ? (S912) | gxm_q201_2g_1gbit

I have an Alfawise S92 (S912) that was installed with CE a couple of years ago and it has been updated up to 19.2 and works flawlessly.

A friend of mine has the same box and has asked me to install CoreELEC to it.

I download 19.2 but the dtb is not in the device tree.

How can I proceed to get his box working ?

Amlogic 912 Soc didn’t survive the times aka CE 19, search for CE 9.2.8 classic, not - ng.

I am not sure I undertand how this works.

My own S92 that works, is it really on 19.2?

If I copy just the dtb.img from my SD card to the SD I intend tu put in my friend’s box, will it work ? Or should I install CE 9.2.8 classic and then wait for the updates ?


No, this Soc will stay for the moment at CE 9.2.8. Download generic img for 9.2.8 and install it on SD card.
Don’t know what version of CE you have, sure isn’t CE 19. If it is the same box with same specs you should be able to copy the dtb from your box to another.

Damn, you are right. My bad :blush: My Alfawise is on 9.2.8. My Beelink is on 19.2.

Should I mark “solved” or just delete the whole thing ?

No, no need to delete, maybe someone has same issues with 912 Soc and bumps into this at a forum search. Solved would be better! That would be my choice, you decide anyway, it’s your post. :ok_hand:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.