[solved] Recovery deleted?

  1. no expectations

I fully know that ceemmc is unsupported for my device. I do not expect support at all, but if somebody wants to offer thoughts or ideas, I would be grateful.

  1. where I’m at

I use a “Nexbox A95x” with a S905X Chip, 2 GB Ram and 8 GB eMMC.

CoreElec works. It works very well. normal builds and ng-builds. all from SD-Card.

Nothing else works, and I can’t seem to find a way to do anything with the eMMC.
There is no Boot Logo and no lying Android. Just a Black Screen, when no or any other SD-Card than one containing CE is inserted.

  1. what I tried (everything while pressing the reset button and without):
  • burncards (Amlogic Burn Card Maker): black screen
  • USB A-A Cable: PowerLED turns on (blue) but Computer doesn’t see a device (neither in Amlogic Burn Tool nor in device manager), even if I additionally connect power then - black screen
  • SD Card with TWRP and DTB from original Firmware: black screen
  • use CEEMMC again: doesn’t work, as the expected partitions don’t exist
  • setenv upgrade_step 2: no change
  1. how I got here

by being stupid.

before using CE (before there was CE) I used LE (kzaq’s builds). and I had it install(ed)tointernal. I don’t even remember if that went completely smoothly back then, but I think it did. then I used CE for years. now, I wanted to try the NG-builds. So I put one on an SD-Card, rebooted with the reset button pressed, and it worked. I decided to put it on the eMMC, because the LE installation there had not been used forever. I did read, that I should reinstall the original FW first, but I thought: why should I? I don’t even want it. CEEMMC (-x) did seem to work, didn’t complain. but now, there is only the black screen. and no way I see how to repair it.

I do not know, whether any of the above methods worked before using CEEMMC, I had never tried a burn card, Amlogic burn tool or TWRP before. I have never seen the lying Android, because I just never went there. LE did still work from eMMC, as I booted it once before using CEEMMC. One thing that definitively changed is the loss of the “Nexbox” bootlogo. That was there before using CEEMMC and now it’s not, regardless of whether I boot to CE from SD or to the black screen doing anything else.

so if (and only if) somebody is interested: do you have any further ideas?

I’ll be honest I don’t necessarily have a solution, so much as experience from what I had to do to get NG builds on my S905x devices running nicely from eMMC and uSD. Hopefully this can help you towards your own solution.

Just to clarify does it still boot to CE from mSD and won’t boot anything from the eMMC, or is it totally bricked after trying to install to the eMMC?

What version of Android was on the box originally? The reason I ask is that the two S905x boxes (An X96 2/16 and A95x 1/8 clone) that I’ve installed NG builds to the eMMC both required an Android 7 firmware for (from what the devs surmised) the Android 7 boot loader. Both of my boxes would boot the NG builds from mSD and sort-of run with the original Android 6 boot loader installed, but were plagued by segmentation faults that would essentially crash the box at random intervals. I only discovered the segmentation fault issue while trying to restore my tar.gz compressed setup from the command line.

Installing Android 7 firmware with the AML USB Burning Tool (for the boot loader) might be a step towards a solution to your overall problem, but on the same hand, experimenting in this way might brick your box entirely if you’re unable to find a working ROM for your box. If your box is already bricked, you don’t really have anything to lose, but if it still functions in some way, I would think very carefully before proceeding.

I seem to recall people in the forum here referring to an A95x S905x Android 7 rom that installs quite happily to many S905x boxes: mentioned here. I’ve personally used a Tanix TX7 firmware (google: HQYG-TX7-nikodi-20180104 ) because it has installed on the numerous S905x boxes I’ve had over the years.

If you’re having no joy getting the USB Burning tool to find the your box, you may have to Short Pins on the flash or nearby components to get the box to wake into a restore-ready state for the software. I use a bit of 30 gauge wire-wrap wire. Do your research.

Hopefully some of this helps. Good luck!

1 Like

Thank you,

Clarification: it happily boots CE from mSD, this is why I’m weary to do anything that might actually brick it.

Original FW was Android 5.1, I think. I have downloaded a 6.0 and a 7.? FW that should be made specifically for my box, but as I wrote above: no (easy, described all over the internet) way to flash it.

I have read about shorting the pins, but it seems excessive, considering that it does work from SD. It seems to me, that having a running system should open up some way to flash it “by software”. As in: the bootloader seems to be “ok”, I don’t want to touch it, I just want to write something to the remaining part of the eMMC that is just not doing anything atm.

It also seems odd that the Flash Tool and burn cards don’t seem to do anything, like not even start to do anything, as I have read that Amlogic boxes are almost “unbrickable” because you can “always” flash them in these ways. I would really like to find out what is really broken.

thanks again for your thoughts.

I had an issue with an old Mini m8s Pro N95 S905 last week
using latest Amlogic Burning Tool V 2.2.0
Not recognized with this version.

I then installed Amlogic USB_Burning_Tool_v2.0.8
It worked straight away.
If you want to try it let me know and I’ll upload it for you.

1 Like


yeah, I would be willing to try, so please.
another related thing I don’t quite seem to understand: what do I need to uninstall before trying out another version of the burning tool? do I need to uninstall the drivers some way? how do I check whether it’s clean?

thank you in advance!

As I recall, Uninstall the USB Burning tool and separately uninstall the World Cup Drivers from your device manager. You may need to select the show hidden devices option. (its been a while since I’ve had to do any of this so I might be over simplifying it.)
After that it doesn’t hurt to reboot and then run the installer again. Depending on the USB Burning tool version, it might have an executable to directly install the World Cup Driver.

As I also recall, there were numerous detailed posts about using the USB Burning Tool on Freaktab describing Installing/Uninstalling etc.

Also, if one USB port doesn’t work, try another. The old laptop that I use for any windows-only stuff doesn’t like finding boxes on all but one USB port.

1 Like

I’ve DM the link

1 Like

thank you. that did the trick.
version 2.08 connected and I could burn the rom.
thank you so much!

(now I’ve got a different problem: my Logitech Harmony Hub can’t connect to the box in the ng-build anymore, it does without issue in the old kernel build on the other mSD. when I try to connect the notification says “input/output error”. strange. but that should probably be its own thread)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.