[SOLVED] Several issues on Odroid N2+ 4G, 19.4 fresh install


I just did a fresh install of 19.4 on an Odroid N2+ 4G, installed on eMMC.
A few serious issues:

  • When setting display to 3840 × 2160 @ 60fps (or any fps setting), the image seems interlaced, no issue when setting display to 1920 x 1080.
  • No passthrough settings when enabling passthrough with HDMI output. So any video is played with Multi-PCM output.
  • When trying to play several videos (4K HDR, 1080p SDR, …), I get a loss of signal.
    Absolutely none of these issues when using legacy image.

Any idea?

CoreELEC troubleshooting steps.

Video troubleshooter.

It was working on legacy release, I didn’t change a cable or nothing.
For the passthrough issue it’s solved, I forgot to set the settings to expert.


Edit: this only apply to ceemmc install!

Wrong topic? I don’t see any link with my issues.

Repeat the fresh install using SD card, whithout any addon, enable expert settings and check.
I´m running CE on N2 and N2+ whithout without the issues you described.

That’s what I did, I’m only using eMMC, not SD card.
After investigating the issues, it seems there’s something with the setup N2+ > AVR (Marantz) > TV. But it’s strange that the issues didn’t occur with legacy version.

Best choice will be fallback to stable version 19.3 and wait for final 19.4
CE 19.4rc1 & rc2 was removed by developers, there are some issues.
I use nearly the same setup:
N2+ → DENON AVR → 4k TV
Configured CEC on N2 and HDMI Setting on TV

It possible something different.
I couldn’t repeat your issue also.
Try to set Use 4:2:2 colour subsampling option and reboot, try different cable, check that HDMI port on TV configured correctly(if it different than in working solution)

I’ve checked and indeed the AVR was not connected to the good HDMI input (I don’t know how it could have worked before).
The input was maximum 4k @ 30fps, and now it’s 4k @ 60fps.
Thanks anyway for your help!

Well, the last issue now is a loss of signal after stopping playback. Only when the Odroid is connected to the AVR.
/sys/class/amhdmitx/amhdmitx0/disp_cap seems standard:


This one was the “Sync playback to display” enabled. Everything is solved.

Where did you find “Sync playback to display” in 19.4?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.