[SOLVED] - Tanix Tx3 don't show 4k

I have a Tanix TX3 Max, with s905w. I have installed the latest stable version of CoreElec (I used the same dtb.img from Tanix TX3 mini) and it does not show me the videos at 4k. In Settings / System / Screen resolution it doesn’t let me choose that resolution, it only allow 1080p as the maximum resolution. I read that it is recommended to choose 1080 for the gui, but later when playing 4k videos it does not change the resolution to 4k.
I’ve already tried the 4: 2: 2 color option.
Before install CoreElec, I used LibreElec and it did work at 4k.

Thank you!

Please verify that your TV and HDMI cable support 4K, keep in mind that HDMI 1.4 only reaches 4K - 24Hz and HDMI 2.0 only reaches 4K - 50 / 60Hz

1 Like

On LibreElec it worked in 4k + HDR 30fps (the maximum that allows the s905w) with the same cable and HDMI input.

Your post is a little ambiguous when you say it does not show you the videos at 4k.

Do you mean it shows you nothing at all or that it displays them at 1080?

1 Like

It displays them at 1080p.

Just to clarify, do you have any 3840x2160 resolution options in the display settings?

1 Like

@lillypop try switching off everything and then switch on your TV and avr first, choose the input that the tanix is connected to, before switching on the tanix.

1 Like

No, that resolution did not appear in the resolution options, but I solved it thanks to @blizz05.

Now it works perfectly and 2160p appears in resolution option. I configured the gui at 1080p and CoreELEC autoswitch to 2160p + HDR when I play 4k + HDR content.
Thanks @blizz05, and thanks everyone!!

You could also manually create a /storage/.kodi/userdata/disp_cap file so you do not need to worry about which device you turn on first.

1 Like

Thanks to everyone!

You are welcome @lillypop. Glad that it worked for you. Yeah you should use that file that adamg mentioned, wasn’t sure what the exact name and command was.

1 Like