[SOLVED] Three of four name resolutions attemps are failing

Hi CoreELEC friends,

I’m new to CoreELEC but I’m log therm user of xbmc/kodi on linux. I’m having troubles with my new CE system running on ODROID N2 and specially with all stream related add-ons.
I have this behavior on two releases. I’ve tried it in nightly and on stable 9.2.2 and its the same.

So what is happening is, that there out of four stream requests are failing with timeout. This happens through all addons line twich, youtube, arte+. Onces the stream started, its is fine so far. But every time the add-on tries to buffer or refresh the list, there are timeouts.

The log is saying curl file timeout,

ERROR: CCurlFile::Stat - Failed: Timeout was reached(28)

then the following python exception is saying that’s the name resolution.

ERROR: EXCEPTION Thrown (PythonToCppException)
Failed to establish a new connection: [Errno -3] Temporary failure in name resolution

I’ve verified that waiting for network is on. There is static IP set up on that box. There are changes in advancedsettings.xml. Anyhow, whatever I change, the failure stays and it make all add-ons nearly unusable. btw, all LAN resources are being played flawless so far.

complete log:

Can anyone help me to solve this behavior, please? What can I change adjust or diagnose more to get it solved?



god damn, I just found there has been a IP conflict in the LAN :slight_smile:
cheers to all and sorry for bothering