Some movies are unwatchable, they crash and reboot device

I really can’t get my head around this problem. I suspect it has something to do with h265 files or corrupt file transfers, but I’m not sure. here are the logs:

http://ix.io/2rHX
http://ix.io/2rHY
http://ix.io/2rI1

Some Movies crash and reboot the device. Forwarding in the failed movie reboots the device again. These movies become unwatchable on the Odroid N2 with CoreElec, while my Kubuntu-PC plays them well with Kodi, same with RasPi3B+ with LibreElec.

I usually use a USB3-HDD to store and watch the movie files, but the same issues happen, when I transfer the movie files to the SD, I use CoreElec 9.2.3, fresh installed on a MicroSDXC UHS-I-Card (Samsung Evo Plus 128GB, 100/90 MB/s) in the Odroid N2.

Can you please cut a sample from one of the movies then test if it still reboots the device. If it does please upload it and ping me with the link.
Thank you.

I’ve cut a sample and send the link to the download directly.

In VLC Player the file plays without crash, but it looks like there is a missing frame or something where CoreElec always crashes. Sometime a forward skip can help to prevent the crash and reboot, but it’s also taking a long time to skip and sometime crashes anyway.

At which point is the crash with the video. I cannot force it to crash here

it’s 0:17. exactly when the scene changes.
at 17 seconds into the Video file, the player freezes and the device reboots, but leaving no trace of the stopping time. so in case the crash happened 1 hour into a movie, you’d have to fast forward to that point.

It doesn’t crash here.

then my only hope is a different stronger power supply, even though mine has the Hardkernel recommended configuration of 12V/2A, that’s 24 Watts. Could the HW be crap? I bought the N2 in march for HDR-Movies with CoreElec.

Option 2 to test is the Transfer of files for playback, maybe some data packets get corrupted in the process of copying to the HDD or microSD. But then, the file that is corrupted plays well with your N2 CoreElec…so no point in that. crap

Thanks for your help @Ray

Is it the HK power adapter or something you bought off of ebay/aliexpress?
I’d try a different PSU. I had one fail on a chinese box, which lead to random crashes as well.

Did you try Nightly?

I made several tries with a different PSU and with the latest Nightly, first with default settings (GUI 2160p/24) and another try with 1080p60 GUI. Same. Here’s the crash log after the second crash and reboot: http://ix.io/2s8b

side notes:
I also tried the same CoreElec version 9.2.3 of another install on another SD. no success either.

The PSU I use is a leftover from an External HDD or DVD-Writer, no problem occured there previously as far as I can recall. The second PSU is from another Ext. HDD in active use. both are 12V 2A.

The crashtest.mkv file (I’ve tried with all tests and send to ray) ran from the MicroSD of the CoreElec-Install

The crashes are not random. They happen always at the same time and are reproducable. The movie that I cut the crashtest file from had several crash points. I used ffmpg to cut the mkv testfile sample, lossless, so the format was left untouched.

the crash part that I choose is when the movie rip had a kind of an interuption like a frame drop. It’s a change of scene in the movie, with the picture going black for a short time. I could hear all audio stop for a bit of a second on other players, when the screen turns black for the scene change. When other players like VLC or Kodi (Ubuntu Repo v18.6) on my PC just hop over it and continue, CoreElec on the N2 crashes and reboots.

edit: restart not reboot

I use emmc no idea if that matters. Do you know how to ssh into the device?

Ssh into it and run:
journalctl -kf

Then start the video until your N2 reboots. Send me the output from ssh until connection is cut.

@Ray: https://gist.github.com/NRG-R9T/e45a462ec418e4a50f7438d627ff0d97

Started CoreElec, ran the file and cut the log at that point, just when it crashed, following reboot after 17 seconds excluded. funny that the file crashes at second 17 also. :laughing:

edit: restart, not reboot.

I think we have different definitions of reboot. For me reboot is that the whole device crashes and restarts maybe. I think you mean that kodi crashes and is restarted.

What skin and addons do you use?

ah yes, actually it restarts. you’re right, sorry for my less exact terminology.
I use “the crew” add-on and default skin, but the test this morning with the nightly was freshly installed without any extra add-ons and crashed and restarted also.

This is strange. I tested it again. N2 current Nightly. At 17s there is a little skip/drop but all is fine.

It could well be, that I need an eMMC as the main drive. Maybe that would do the trick?

From Yor log:
blk_update_request: critical medium error, dev sda, sector 113248512
EXT4-fs error (device sda1): __ext4_get_inode_loc:4467: inode #3538945: block 14155808: comm JobWorker: unable to read itable block

You can try eMMc, but I don´t believe
Could You try to play the video file via network share(NFS/SAMBA/NAS) ?

I missed that. So probably the SD card is broken.

thanks guys! I will try a network share later; need time at hand to do that.
A short test with the nightly and on a different SD resulted in this: https://gist.github.com/NRG-R9T/47ca9beb1bdea9ff90ae7b5777f6840f

About | FAQ | Terms of Service | Privacy Policy | Legal Notice