SSH key auth refused


#1

Hi,

I have tried the latest nightly build and I found a ssh key authentication is not working properly.
Compare with the last release did you changed anything here?

Thanks,
Gyozo

2018-12-30 12:08:18 Connecting to 192.168.0.162 port 22
2018-12-30 12:08:18 We claim version: SSH-2.0-PuTTY_Release_0.70
2018-12-30 12:08:18 Server version: SSH-2.0-OpenSSH_7.9
2018-12-30 12:08:18 Using SSH protocol version 2
2018-12-30 12:08:18 Doing ECDH key exchange with curve Curve25519 and hash SHA-256
2018-12-30 12:08:19 Server also has ecdsa-sha2-nistp256/ssh-rsa host keys, but we don’t know any of them
2018-12-30 12:08:19 Host key fingerprint is:
2018-12-30 12:08:19 ssh-ed25519 256 db:b8:40:f2:eb:d3:75:c2:e5:f3:48:e2:15:21:b2:63
2018-12-30 12:08:19 Initialised AES-256 SDCTR client->server encryption
2018-12-30 12:08:19 Initialised HMAC-SHA-256 client->server MAC algorithm
2018-12-30 12:08:19 Initialised AES-256 SDCTR server->client encryption
2018-12-30 12:08:19 Initialised HMAC-SHA-256 server->client MAC algorithm
2018-12-30 12:08:19 Reading key file “X:\MyPrograms\putty\itsh.ppk”
2018-12-30 12:08:19 Offered public key
2018-12-30 12:08:19 Server refused our key
2018-12-30 12:08:19 Attempting keyboard-interactive authentication
2018-12-30 12:08:19 Server refused keyboard-interactive authentication

#2

AFAIK nothing changed.

I always been able to ssh with keys, including latest nightly. Haven’t tried Putty though. But works perfectly from a Linux system.


#3

Same here with linux. libssh was updated recently iirc. Make sure to use the latest putty


#4

Thanks for prompt replay. I generated a new key and now working without any issue. My old key is “outdated” it is more than 7 years old :slight_smile: .


#5

It was probably an old DSA key, which aren’t supported by newer versions of OpenSSH anymore.
Only the much more secure RSA keys are supported.