Start from internal memory very slow.

I have a H96 MAX smart TV box Android 7.1 TVBox 2GB Ram 16GB Rom S905X and when starting coreelec (9 and 8) from the SD it starts in just over 30 seconds, but when installing it in the internal momoria (installtointernal ) it takes four to five minutes to start kodi.
Should I install it in another way?
I find it strange because otherwise it works perfectly and very fluid.
Thank you very much for your help.

Unfortunately the Devs don’t support Installtointernal CE.
Strange behaviour. That is a Very Very long wait for Kodi to start.
I run a S905X 2GB / 16GB H96 Pro H3 Dongle with CE Internal
That boots up real quick.
Is CE Internal Install a Fresh clean Install or did you update from LE ??
I did a Clean Install.
I have LE Krypton on SD Card with this Dongle , Dual Booting so pretty much the same as your setup.
Try a Clean fresh install to see if that solves it.

I’ve been from Android, from coreelec erasing everything and without deleting everything happens to me from libreelec and coreelec. I do not know what to do to have a normal start. I’ve put atv experience and it starts in a few seconds. It only happens to me with coreelec or libreelec.

Sorry I forgot to say that I think it is a DMYCO H96 MAX clone smart TV box Android 7.1 TVBox 2GB Ram 16GB Rom S905X.

It must be a complete new burn of CE on SD Card .

Does a clean install of CE boot correctly from USB / SD ?

Yes, it starts well and in less than a minute. I have tried it from the three usb that it brings and from the Sd in clean and with the addoons installed in the sd.

I have set CE 8.9 and 9 using RUFUS and the program to create sd / usb of libreelec. I’m using a 32gb sd from Samsung, I have another 16gb sd I do not know if that could change something

And with that CLEAN fresh sd card or usb image ,
Did you install to internal.

Not interested with addons installed.
Leave that out of your install internal for now.

The sd formatted and with CE 9 without user data and nothing the least it has taken is about two and a half minutes.

You are saying internal install is taking 2.5 minutes to boot?? after using fresh CE Sd Card to install internally. ??

I had the same problem starting from 8.99.2 (I think) before I moved to SD with internal storage. Booting from internal took minutes.

I remember looking at the system log and finding a process that would repeat every 5 seconds or so until eventually Kodi started. Unfortunately I didn’t save the log nor posted here because I thought you didn’t provide support for internal installs.

Anyway my advice would be to look at dmesg

Did you solve it ?? Or gave up and use SD Card only ??

As I said, I moved to booting from SD while using the internal storage. I didn’t solve it.

I just installed them with a new SD and it took a minute and a half to start from the internal memory.
Well it seems that it has improved a bit.
Is it normal I think or is it still a long time?

In my experience it was very inconsistent. A boot may take much longer than another for no apparent reason.

If that’s the case for you, too, than it would be very useful if you could provide a system log, so the devs could have something to work with if they wanted to try fixing this

If you can explain to me how to do it.
I will do it without problems.

How many times does it have to be repeated:

Did you actually read the discussion?

Sorry, you can repeat it to me.
If you look further up you will see that neither the moderator has told me anything.