Strange issue when playing video files & CEC

I got an Amlogic S905 box, and when I play some video file, before the video is starting I got black screen for 3-4 sec than I see the CEC message on TV top right “HDMI 4” port and then video start. I don’t know why this happens. I tried to disable CEC from input -> peripheral, but with no result. I’m using latest version 9.0.3.

i made some shell test:

My Sharp have 4 hdmi, and the box is on hdmi 3

All my problems with video playback were solved with this No HDMI signal after CoreELEC splash screen

I noticed when I play video that CEC shows me “HDMI 1080p 24hz” and when i press STOP i see “HDMI 1080p 60hz”

I found this option:

settings->player settings->Video->adjust display refreshrate
and i set as “OFF”. that could cause problems?

You should enable the “adjust refresh rate” switch.
But the pause when starting a video with another refresh rate than your GUI is absolutely normal, because during that time your TV switches to the refresh rate of your video.
If your TV wouldn’t do this, your videos would begin to stutter.

Ok, so it’s normal that 4 sec pause, black screen, the message "HDMI port … "? Because i never had this issue before with coreelec…

The duration of this pause highly depends on your TV. My TV also needs about 3,5 seconds to switch between resolutions/refresh rates.
If you didn’t notice it before, you probably never properly switched to the right refresh rate and your videos were stuttering (maybe you just didn’t see it).

I tested with that option “OFF” and video doesn’t seems to be “jerky” it’s very smooth… but i’ll keep on eye on this. A couple of times I happened to have to set the overscan because the videos exceeded the edge of the screen. It happened to me several times as if it had not accepted the configuration. very strange.

Did you activate any resolutions/refresh rates in “Settings > System > Display”?
This would also force your TV to switch to the right refresh rate.
For the best experience I suggest you to live with the pause, because it’s there for a good reason.

Regarding your overscan setting:
You really don’t want this…seriously.
The best option is to eliminate this overscan in your TV settings and reset the overscan setting in CE.
Try to find an option for the aspect ratio or zoom in your TV and set it to something like “just scan” instead of “16:9” for this HDMI input.
The picture quality is much better, when e.g. a 1080p video is natively displayed on your screen (pixel-to-pixel match) instead being resized before being send to your screen.

In Resolution there are 5 settings, but only 1 is light green: 1080p. As regards Whitelist there are lot of resolution in list. Also Refresh rate is set as 60. Now i try to search that option on TV for overscan on my SHARP Aquos Quattron 40’’.

@relkai i found an option on TV:

MODE: WIDE or dot by dot, could be this?

“Dot by dot” sounds good - try it.
You should also deactivate all white list settings and activate “adjust display refresh rate” instead.

I can’t see the option “adjust display refresh rate” under Settings / System / Display

Take a look at “Settings > Player > Videos”

Ok, found it, green on “On start stop” and I’ll have to live with that 4 sec pause :smiley:

Yep, right. :+1:
Is your overscan setting also fixed, now?

I reset overscan to (0,0) on every angle (top right, bottom right).

Btw…you can also set “Delay after refresh rate switch” in “Settings > System > Display” to pause the video playback until your TV successfully switched the refresh rate (in seconds).
Otherwise the video playback starts before your TV is ready.

That option was set as “OFF” and sadly the video starts after that pause :frowning:

You should set it to the same value your TV needs for the switch (~4 seconds - try a few values to find the right one).
This way you won’t miss a single second when switching the refresh rate.