Sundtek SkyTV Ultimate - DTV_CLEAR failed [e=Success]


#21

We only support Amlogic at this time. So IF this is really helping I can make this Amlogic specific.


#22

for dvb-s, this was definitely an improvement. However there is still room for better, as on some UHD demo channels where you have very high bitrates the stuttering still occurs. This is not visible on an RPI3.

@chessplayer: could you test it on the dvb-c/t2 tuner? But I expect lower bitrates on these.


#23

Well, what I can tell you is that there is no picture in Sky UHD (Sport and Sport Bundesliga). After the World Cup (did that really take place this year, not sure … ;-( ), I was able to watch the replays on Sky Sport UHD with no problem at all. When I have time (which I suspect will not soon be the case), I will test on an RPi3 and also with other tuners / boxes (Wetek Play; XBOX One), just to make sure whether it is down to a box / tuner or maybe my subscription (the replays may have been free to air), although my subscription should include UHD.

I cannot very well complain to unitymedia or Sky, however, since I am not using their standard Horizon or Sky Q boxes …


#24

@chessplayer: Thanks for the hint.
Without hijacking the thread, just a side note: Does the xbox tuner work on the amlogic devices as well ? It’s a cheap at least.


#25

Yes, it does. That is a question of the kernel and drivers (@CvH over at kodinerds took care of that. It will even be recognized directly by the Linux kernel starting with 4.18, I think.

But do not expect too much from the tuner. It is definitely not in the same league as the sundteks. You WILL see artefacts (and, of course, it is only for DVB-C and DVB-T(2)) …


#26

You can try to switch to isochronous

/opt/bin/mediaclient --transfermode=iso -d /dev/dvb/adapter0/frontend0

replug and test.
The default mode is bulk (–transfermode=bulk) would switch back to the original mode.

however there was a bug on some amlogic devices (definitely not on all of them because we’re using an amlogic Android unit without any problem).
We’re about to release the android driver next week (no rooting required and it seems to work well).


Wetek Play 2 vs Sundtek tuner
#27

I’ve added this to the sundtek start script and rebooted.
I don’t know if after running this command it’s necessary to replug the stick.
Is there a way to verify if the transfer mode has been changed ?
But now I’ve noticed that on 4k channels there is no more stuttering (Tried with serveral channels on Astra 19.2E)


#28

The command only needs to be started one time, the setting is stored on the tuner.

Only the logfile tells in which mode the tuner is in. Bulk or Isochronous (iso).


#29

Thanks for the info.