Support added for S905X2, S922X and A311D!

I have am6 s922 first revision, not “b”. Do I have a chance to try your product? No time to go through dtb options. Please indicate a specific specific option for Ugoos am6 s922 first revision. Thank. Or indicate the direction where I should go with this revision of the SoC …)))

Don’t confuse revisions of boxes like 922X and B922, it’s the same s922X soc.
You can try beelink gtk dtb file, it possible the same.

I do not confuse the revision boxes. For example, ugoos am6 for tests was with the first revision, I now have it. And for retail sales they have released a box with a new revision of the processor “B”. But their Android firmware is the same for all revisions of the processor, unlike beelink
ok, try king)

I have x96 max s905x2 box with 4G/32G config. Wifi is AP6356SA.

I managed to install CoreELEC nightly from 7/18 via a pen drive, but now it won’t boot. I’ve tried using pen drive in both USB2 and USB3 slots, and using micro sd card slot. When booting from pen drive it boots into android recovery. When booting from micro sd it comes up with message same as July 18 post from SamWilson about “Error in mount_flash” etc.

I tried the dtb given by boot2k3 and theCoolest

I have android device tree here from /sys/firmware android folder - hope it is the right file it is fdt file.fdt (88.1 KB)

Any ideas or is this still very much a work in progess? Thx

I have your same box and it boots from Pendrive in USB3 slot. Using Terminal Emulator

Thx - how do you setup and use Terminal Emulator? If it’s too complex, I’ll wait and see if an easier solution comes up. :slightly_smiling_face:

EDIT: found the how to on CoreELEC site:- How to install CoreELEC

it should work with this 4gb dtb


check that you installed -ng Generic image and renamed dtb file to dtb.img

In android just download from google store the app terminal emulator. Then run the app and write the command reboot update. The pen with CE should already be in USB 3 slot when you apply the command.
It should reboot in CE.

Just tried and it still boots to stock android recovery. I’ve verified it’s a s905x2 and has 4gb ram and 32 gb rom and wifi is ap6356sa. I tried with dtb.img from boot2k3 and it’s definitely the -ng image I installed.

I also have “Reboot to LibreELEC” installed and tried that but same result - boots to recovery.

Weird that it installed ok, but now won’t boot. Is it a dtb issue or locked bootloader???

try different usb stick or sd to usb adapter.

Thanks for the help guys!!

Used an old USB 4gb pen drive instead of new 32gb micro sd and USB sd card adapter and all is working fine now.

Thx again :slightly_smiling_face::slightly_smiling_face:

Any chance we could get it to boot from micro sd slot in the future??

Yes it will be working in tomorrow’s nightly.

CEC, IR also works now and Bluetooh/Wifi will work in some devices.

1 Like

Brill!

BTW, which device do you have?

I’m finding rebooting with a USB pendrive in USB3 slot is very unreliable. Sometimes it works, but when it doesn’t work, I have to do a fresh re-install to get it back again :unamused:

Terminal emulator just reboots to android recovery, and only a fresh install revives it.

I have the T95X2 which was the cheapest 4GB device I could find for development but it doesn’t have Gbit but it does a half decent wifi chipset.

If your having problems with USB booting then you must have a poor flash drive because I haven’t had a single issue, I prefer to use flash drives as they are much faster and easy to swap around than SD cards.

Thanks for the info. I did post in an earlier message the android device tree from my firmware for the x96 max 4g/32g box. File is called “fdt” -fdt (88.1 KB) - it may be helpful in the future - also the wifi chip is AP6356SA. Ethernet is something I don’t use.

Are the changes you made for the S905x2 in “coreelec-9.2” branch? If so, I can compile the image myself - thx

It is, I can’t remember if the top off my head if the firmware for AP6356SA is added though, the driver is there already though.

If it doesn’t work then SSH to your device and type dmesg | paste and paste the link.

I just tested CoreELEC-Amlogic-ng.arm-9.1-nightly_20190722-Generic.img.gz with 2gb dtb on X96S, an Android TV stick that’s based on S905Y2 (it’s the same as S905X2 except designed for TV stick). There is no Ethernet on the TV stick, only WiFi (both 2.4GHz and 5GHz band). The stick boots right away to CoreELEC with this image…

Boot: OK (with g12a_2g.dtb)
WiFi: No
Audio: OK (didn’t check passthrough though)
IR Remote: No (perhaps there is no config file comes with this image but I couldn’t build a config file as I have no network access)
x264: Plays OK
x265 10bit 1080p: OK
CEC: OK

WiFi chip on the X96S is Ampak AP6255 which is the same as that on Khadas-VIM.

Thank so much for making such progress. Before today, I thought my X96S stick could never run Linux based media player.

Thanks again for all developers’ hard work.

The tanix tx5 max, I do not recommend it in my case I stop giving image. I think it was defective.

Great work team, just installed 22/7 nightly on X96Max (4g/32g) boots from SD card no problem, used the, “g12a_s905x2_4g_1gbit.dtm” renamed to dtb.img of course. loaded vfd.conf and remote files. Displays works, wifi works, bluetooth works, wired ethernet all good, remote works. seems vert stable, will use over the next few days and report any issues. Thanks all :slight_smile:

1 Like

Managed to compile and install “coreelec-9.2” ng branch and must say I’m well impressed! Using X96 Max with 4GB/32GB configuration with S905X2 SOC. Installed on micro sd card without any issues.

I don’t use IR remote (USB RF remote instead). Wifi is working - both 2.4 and 5.8 GHz. CEC is working, playback is awesome (HW decoding is doing a great job so far). RAM is showing as 4gb and flash as 32gb (both correct). Bluetooth is enabled but I don’t use it - I don’t use ethernet either - I am using the “g12a_s905x2_4g_1gbit.dtb”.

So far, excellent playback on a very nippy device.

Much kudos to you and your team :smiley:

1 Like