Support added for S905X2, S922X and A311D!

i have try o mine USB stick no luck

Perfect, so boot correctly. In my case, wifi does not work either. The wifi of my box is: RTL8822

mi bad as using rong image, boot ok using usb stik, and ethernet is working, ram 4g ok, wifi ins´t, comand powers down ok, but don´t powers on de device

Hi all
I have X96 Max 4/64
Tested with generic img , dtb s905x2 with usb stick but no boot
zambu man : using rong image ?
what is correct img ?

x96 max 4/64
Boot from usb 3.0
ethernet ok
wifi no ok
bluettoth no ok
4 gigas ram detected.
Great step devs.
I dont know what vfd.conf can try for display @TheCoolest

Good, after doing tests in my tanix tx5 max (4/32) I can say that this build is going incredibly well, being the first. In principle, I leave these reports.

Boot SD: Not working
Boot USB (Pendrive): Working
Gigabit Ethernet: Working.
Vdf (FD628): Not working
Remote (meson-ir): Working
HEVC 1080p: Working
H264 1080p: Working
Audio: Working
USBs 3.0 and 2.0: Working
4 GB Ram: Working with the thread dtb
Wifi and Bluetooth (RTL8822): Not Working

I need to try 4k both HEVC and H264.

Mecool KM9 PRO 4GB/32GB

Boot SD: Not working
Boot USB 2.0/3.0 (Pendrive): Working
Ethernet: Working.
USBs 3.0 and 2.0: Working
4 GB Ram: Not working with the thread dtb. showing only 2GB
Wifi and Bluetooth: Not Working

where’s the reset button?

its generic whith dtb post by boot2k3

1 Like

av hole, back side

I need the android dtb.

To help Devs with adding WiFi/BT support, these are the modules in some popular boxes.

Mecool KM9 PRO - AP6236
X96 Max/A95X Max/MECOOL KM3 - AP6356S
Beelink GT1 Mini/X2 CUBE/T95Q/Mecool KM9 - AP6255
Tanix TX5 Max - FN-Link 6222B-SRB

Sorry for bothering you, I could also see the tanix tx5 max: (38.6 KB)


If somebody can collect uart logs for not working boot process from sd card, than please collect and upload…

Please try this one:
tanix-tx5-max-vfd.conf (1.2 KB)

@TheCoolest I just tried it and it keeps coming “boot”. You have to rename it to “vfd.conf” and put it in “/storage/.config” no?

Yes, you need to do that.
If it doesn’t work, then reboot and then post the url that this command produces
dmesg | paste

@TheCoolest Here you have:


mount -o remount,rw /flash
fdtput -r /flash/dtb.img /gpioleds/net_red
fdtput -r /flash/dtb.img /gpioleds/net_green
fdtput -r /flash/dtb.img /gpioleds/remote_led

And see if VFD will start working.

Update: X96 MAX S905X2 4G/32G
SD No boot
USB pendrive boot
If use dtb (2G) from nightly image no ethernet.
If use dtb from @boot2k3 from this thread, ethernet works. (Many thanks @boot2k3 for your remote files. They work perfect).
Wifi and bluetooth not working
Detected 4 Gb of ram
2K files (either h264 andd VC1 work perfect).
Analog audio perfect.
4k HDR files need to be worked. HDR works but the image is strangely full of colored horizontal stripes.Picture%202 Picture%203 Picture%204

Many thanks.You are the best CE.
First picture (top to bottom) is 2K file
2nd and 3rd pictures are 4K file