Support for USB DVB-S2 tuner

After a reinstall I did manage to view some channels but performance was appalling, although this may be because I used the wrong driver or the required firmware wasn’t loaded.

According to:-

some firmware is required and it is supposedly included in OpenELEC. How do I check if CoreELEC includes it?

Although, thinking about it can the same firmware be used on both Intel and ARM?

Isn’t the firmware device related it the software the software uploaded to the asic in the chip that makes it work. The Driver is os/procecssor family related.

I agree I have 2 DVB-T tuners and use a usb 3 powered hub without strange things happen. Also if you do a cold reboot I normally de-power the HUB to put the tuners into a cold state.

No the Firmware does not run on the computer / Coreelec box its the software that runs in the dvb-t/s stick/card. It is uploaded to the device when it is spotted on the USB bus in its cold state. I use the same firmware for my usb-t tuner on my PC as in my Coreelec box. The driver on the other hand is compiled for ARM or x86.

The firmware for my PCTV DVB-S2 stick is called dvb-demod-m88ds3103.fw

How can I tell if it is included in CoreELEC?

According to which lists the firmware YES. Your USB may not provide enough power as mentioned or you could try other drivers such as crazy cat.

There’s an awful lot of firmware listed there :slightly_smiling_face:

My device comes with a power supply so it should have enough power, although I’m disappointed with its performance and wouldn’t recommend it to anyone.

Maybe I’ll try with a different driver. How do I tell which it’s using?

Yes I should have realised its a DVB-S Tuner so it needs another power supply to provide power for the LNB (dish). It’s in Addons/Program Addons/Coreelec Drivers. There are 3 different ones coreelec/crazycat and kernal if I remember you could try each until you find the best one.

hello, i have a terratec cinergy s2 usb box version 4, wich is supported in libreelec crazycat drivers, but in an s912 with latest coreelec 9.0.3 it wont loaded correct driver, instead loaded old driver, in my opinion.

please how can i update or recompile crazycat drivers for amlogic 9.0.3 generic?

thanks in advance.

Have you tried the three options in CoreELEC module drivers?

Yes, 3 posibilites tries and no sucsess…

I think problem is montage demodulator wont load correct firmware or something similar…

Sorry for external posts… first one describe the problem, second and thrid are succesful ones on libreelec forum with crazycat parches.

Thanks for reading…

i also plan to buy TERRATEC Cinergy S2 for Beelink GT KING. Will it work in CE 9.2.1?

You can follow this link and it will indicate how this is supported in Linux. There are multiple revisions so I think it is a shot in the dark unless someone here already uses it:

Hello again,

the version i´m using is V.4 (Bus 001 Device 004: ID 0ccd:0105 TerraTec Electronic GmbH)

in ubuntu server as in libreelec, as i has told, is runing perfectly with tvheadend.

but with corelec 9.2 (not tested 9.2.1) not properly detected.


I have the 0ccd:0105 too. Hopefully it will run with CE9.2.x


I bought the H96 Max X3 device, also I have the TBS 5990 USB Tuner.

I installed the latest CE Official version, activated the DVB drivers from the latest kernel module, but TVHeadend did not see the USB Tuner.

What can I do?
How will this work?

Best regards…

Have you tried crazycat?

1 Like


I solved the problem, the problem was with the USB Host, it worked when I plugged in the tuner directly.

Thanks for your interest mate.

Best regards…

Do yourself a favour and get an IP based tuner. I spent years stuffing around with all kinds of USB tuners and never got them running perfectly. Have been using a IP tuner for the last few years and have zero issues. To the extent if I had to reconfigure it I’m not sure I’d remember how.

1 Like

IP based tuner does not make sense unless it is used by multiple clients. And it is not cheap.
I have an experience with 3 USB tuners:
DVBSky S960
Prof 7500
Never had any major issues with them.


Yes - wholeheartedly agree. Either an IP tuner (I use HD HomeRun for DVB-T/T2 and Telestar DigiBit R1 for DVB-S/S2 running third party axe firmware) and/or a separate Linux box running TV Headend (running a recent Linux kernel). I’ve run TVHeadend on VMs running Ubuntu server in the past with IP tuners and that’s been a neat solution. IP Tuners and/or a separate Linux box running TV Headend also means your Kodi CoreElec box etc. doesn’t need to be physically near your antenna/aerial or LNB feeds (only the IP tuners or TV Headend server need to be physically connected)

This approach avoids having to trouble shoot USB tuners every time you replace your CoreElec box…