Sx05RE: Retro Emulation Kodi Addon for CoreELEC, released for testing


#42

Thanks for the config.

I’ve been trying to reproduce your problem, but I just cannot. everything installs and works without a problem. Do you happen to have a log ?

EDIT: I found the problem, will release an update ASAP, will probably need to uninstall the old one first unfortunately.


#43

EDIT: I found the problem, will release an update ASAP, will probably need to uninstall the old one first unfortunately.

Ah, ok. I was planning to uninstall/reinstall anyway (time permitting…), to provide you with the log. I’ll stay tuned, thanks.
Meantime, the update to nb 190215 worked (with tar), and restored the (manual) update through custom channel… but this is topic for relkai :slight_smile:


#44

V2.3 should not have this problem anymore. Please download this one, not sure if you can update the one currently installed, but you can try, and if you run into problems just uninstall the old one first.


#45

@shanti
Done.
As you expected: update on top of the previous version ended up with problems (more or less the same as last time: non configuration, etc… but I didn’t check deeper), uninstalling/reinstalling worked.
Configuring the gamepad in emulationstation was smoother, I missed only two keys: previously was totally unresponsive.
This time I had to configure the gamepad also in retroarch, which didn’t produce any problem.
Thanks!


#46

Hi @shanti, thanks for making available this addon for CoreELEC

I’m quite new to emulators, so I’m having trouble getting it to work

After successfully installing your addon on my S905 box, I’m able to launch it, but EmulationStation complains about not having any system or ROMS available

I did create a ROMs folder in /storage
So I now have, for example, /storage/roms/mame2003-plus with some roms inside of it

Do I have to do anything else to get it to work?

Do I need to install each emulator apart from your addon? Or are they included in it?

Also, what are the images available for download ot your GitHub site?
I’m talking about:

Sx05RE-Amlogic.arm-2.3-Generic.img.gz
Sx05RE-Amlogic.arm-2.3-KVIM.img.gz
Sx05RE-Amlogic.arm-2.3-KVIM2.img.gz
Sx05RE-Amlogic.arm-2.3-LePotato.img.gz
Sx05RE-Amlogic.arm-2.3-Odroid_C2.img.gz

Are they needed for your addon to work?

One more thing, my controller (a Logitech F310) which is recognized in Kodi, doesn’t seem to work in EmulationStation when ES launches. Any tips about that?

Thanks


#47

MAME ROMS ned to be in /storage/roms/arcade

All the emulators are includes and If you are using this as an add-on on top of CE, you don’t need any of those other files.

The game pad should work once you have ROMS installed, it is the same game pad I use and it works fine.


#48

Thanks!

I was able to run it now. And my controller works too :grinning:

By the way, what are the names for the folders of other systems? I mean, like mame2003-plus’ folder needed to be called arcade, is there a list of names for the folders of other systems? Or mame’s case is unique and all the others can be named just like the system? (e.g. atari800’s folder should be named atari800, and so on)

Thanks again


#49

I know I need better documentation but I haven’t had a chance to do it.

if you look around this file you can see all the directory names for the different systems I have enabled in ES:

hope it helps


#50

Your link goes directly to 2.2 :frowning: Should be super fixable though :slight_smile:


#51

Fixed it :slight_smile:


#52

thx :slight_smile: I’m having sporadic loading problems with N64 roms (just hangs at a black screen) sometimes and othertimes it works… any ideas for what I can do to help troubleshoot what’s going wrong? The backup in particular is Super Mario 64 (it also looks like I lost my save game :frowning:).

EDIT: Bomberman and similar don’t work either with Mupen64Plus :frowning: ParallelN64 seems to have slightly better results but still just completely hangs 80% of the time (forcing me to reboot the unit).


#53

80% of the time seems like a very high failure rate, first are you sure your SD card doesn’t have any errors? does this happen on other emulators, specially those that use big ROMS/ISOS?

And second, please paste your logs, there are a few logs I need as well as the usual, sx05re.log that is on the /storage directory and and the es_* files hat are in /storage/.emulationstation


#54

I’m using sshfs and a bind mount (I get around 70mbit/s in Kodi). I thought the machine had hung… but then 007 loaded after like 5 minutes so maybe sometimes it takes super long to load. I’ve reviewed the log files and there’s no real profiling information or similar. Is there a better way to do this (like enabling debug logging or similar)? Alternatively would it be possible to boot directly into RetroArch from the Add-on instead of going through EmulationStation?


#55

You can choose what starts, Retroarch or ES in the Add-on settings in Kodi.
You can enable verbose logs in Retroarch, but I think you need to enable advanced settings first.


#56

Thank you very much for the help :slight_smile:

I’m probably asking in the wrong area but do you think it would be possible to resolution switch to whatever the Core is running as? My display is 1080p/24hz (what Kodi was running as) and I’m not seeing a section to do it in either app :stuck_out_tongue:


#57

I don’t think I follow you. It usually tries to adapt to whatever resolution you have it set in Kodi, so you want to run an emu in another resolution?


#58

Kodi I had media playing 1080p/24hz so when it jumped to Retroarch it stayed 1080p/24hz… native is 1080p/60hz in Kodi so when it jumps it keeps this. paralleln64 seems to max out at 720p otherwise it refuses to start the rom (but I don’t think this is your problem). I’d like my panel to run at this resolution as well because I have post processing on my Bravia panel.

Hopefully that helps explain what’s going on (and why it would be useful :)).


pinned #59

#60

Hi there,
I run CoreELEC 9.0.1 to my 905X box and successfully installed Sx05Re as an addon with the following file “script.sx05re.launcher-2.2-S905.zip”.
I put my Snes roms into /storage/roms/snes folder and they were detected correctly from ES.
My wireless joypad was detected as well and I followed the short guide to configure it. After that everything works nice in the main menu but when I start some rom, before starting the game a small message appears that my joypad is not configured. So when the game is already started my joypad does not work at all.
Can someone help me to fix this problem.
Thanks in advance and good day to all.


#61

Hi there. Thanks for creating this, wish I could use it. I have an old Panasonic Plasma which doesn’t seem to like the Retroarch and EmulationStation GUI’s.

The addon starts ok but when I try to enter Retroarch I get a display very similar to this pic.

image

The same thing happens with the ScottELEC build. Is there some sort of resolution or sync change at that point?

IARL works flawlessly, all videos up to 1080P60 and x265 play perfectly

Lakka goes into Retroarch and EmulationStation ok but with massive overscan which I can not get rid of. Grrrrrrrrr!!

Maybe time for a new tv :frowning: