Sx05RE: Retro Emulation Kodi Addon for CoreELEC, released for testing


#122

The problem is that if you don’t have any ROMS at all that screen does not let you configure your gamepad, which I think its a bad choice in ES itself, that is an issue I need to figure out, I am thinking of including public domain ROMS so that screen never appears.


#123

ok, I entered a Rome and now starts. But when I try to start Rome it does not start

sh: setterm: not found
Input type is 'joystick'.
Configuring 'emulationstation'
Configuring 'retroarch'
mv: can't rename '': No such file or directory
lvl0: 	VolumeControl::init() - Failed to find mixer elements!
sh: setterm: not found

sh: setterm: not found
lvl0: 	VolumeControl::init() - Failed to find mixer elements!
sh: setterm: not found

sh: setterm: not found
lvl0: 	VolumeControl::init() - Failed to find mixer elements!
sh: /usr/bin/ip.sh: not found
sh: /usr/bin/ip.sh: not found
sh: /usr/bin/ip.sh: not found
sh: /usr/bin/ip.sh: not found
sh: setterm: not found

sh: setterm: not found
lvl0: 	VolumeControl::init() - Failed to find mixer elements!
sh: /usr/bin/ip.sh: not found
sh: setterm: not found
==============================================
input config finish command:
==============================================

#124

There should be a file called “/storage/sx05re.log”


#125
Sx05RE Run Log
1st parameter: FBA
2nd Parameter: /storage/roms/neogeo/ssideki2.zip
3rd Parameter: 
4th Parameter: 
Run Command is:
/storage/.kodi/addons/script.sx05re.launcher/bin/retroarch -L /storage/.kodi/addons/script.sx05re.launcher/lib/libretro/fbalpha_libretro.so /storage/roms/neogeo/ssideki2.zip
Emulator Output is:

#126

its funny there is no output from Retroarch, the only thing I can think of is that the roms is not compatible?

try a NES rom and see if that loads,


#127

the snes games start. all the others do not


#128

In the add-on settings in Kodi can you enable loging, after trying to run a game there should then be an emulationstation.log in the /storage folder if I remember correctly. can you post that ?


#129

Here they are:

Emulationstation Log:
    sh: setterm: not found
    sh: setterm: not found

    sh: setterm: not found
    sh: setterm: not found

    sh: setterm: not found

    Sx05RE Run Log:
    1st parameter: MAME
    2nd Parameter: /storage/roms/arcade/orunners.zip
    3rd Parameter: 
    4th Parameter: 
    Run Command is:
    /storage/.kodi/addons/script.sx05re.launcher/bin/retroarch -L /storage/.kodi/addons/script.sx05re.launcher/lib/libretro/mame2003_plus_libretro.so /storage/roms/arcade/orunners.zip
    Emulator Output is:

#130

hey bud, updated the add-on from retail and it nuked my controller conf(!). Haven’t tshooted but an FYI for OTA


#131

Unfortunately if you had an old version and updated with the new that has auto joy-pad configuration it will break :confused: you will need to set it up in ES again. sorry but these are test releases to find all these small bugs.


#132

Weird, controller works in ES but not RetroArch (direct booting into the app); which logs can I review?


#133

post:

cat /storage/.emulationstation/es_input.cfg
cat /storage/.emulationstation/es_log.txt
ls /tmp/


#134
 cat /storage/.emulationstation/es_input.cfg
<?xml version="1.0"?>
<inputList>
        <inputConfig type="joystick" deviceName="Logitech Gamepad F310" deviceGU                                                                                                                                                             ID="030000006d0400001dc2000014400000">
                <input name="a" type="button" id="1" value="1" />
                <input name="b" type="button" id="0" value="1" />
                <input name="down" type="hat" id="0" value="4" />
                <input name="hotkeyenable" type="button" id="8" value="1" />
                <input name="left" type="hat" id="0" value="8" />
                <input name="leftanalogdown" type="axis" id="1" value="1" />
                <input name="leftanalogleft" type="axis" id="0" value="-1" />
                <input name="leftanalogright" type="axis" id="0" value="1" />
                <input name="leftanalogup" type="axis" id="1" value="-1" />
                <input name="leftshoulder" type="button" id="4" value="1" />
                <input name="lefttrigger" type="axis" id="2" value="1" />
                <input name="right" type="hat" id="0" value="2" />
                <input name="rightanalogdown" type="axis" id="4" value="1" />
                <input name="rightanalogleft" type="axis" id="3" value="-1" />
                <input name="rightanalogright" type="axis" id="3" value="1" />
                <input name="rightanalogup" type="axis" id="4" value="-1" />
                <input name="rightshoulder" type="button" id="5" value="1" />
                <input name="rightthumb" type="button" id="10" value="1" />
                <input name="righttrigger" type="axis" id="5" value="1" />
                <input name="select" type="button" id="6" value="1" />
                <input name="start" type="button" id="7" value="1" />
                <input name="up" type="hat" id="0" value="1" />
                <input name="x" type="button" id="3" value="1" />
                <input name="y" type="button" id="2" value="1" />
        </inputConfig>
        <inputConfig type="joystick" deviceName="Microsoft X-Box 360 pad" device                                                                                                                                                             GUID="030000005e0400008e02000010010000">
                <input name="a" type="button" id="0" value="1" />
                <input name="b" type="button" id="1" value="1" />
                <input name="down" type="hat" id="0" value="4" />
                <input name="hotkeyenable" type="button" id="8" value="1" />
                <input name="left" type="hat" id="0" value="8" />
                <input name="leftanalogdown" type="axis" id="1" value="1" />
                <input name="leftanalogleft" type="axis" id="0" value="-1" />
                <input name="leftanalogright" type="axis" id="0" value="1" />
                <input name="leftanalogup" type="axis" id="1" value="-1" />
                <input name="leftshoulder" type="button" id="4" value="1" />
                <input name="leftthumb" type="button" id="9" value="1" />
                <input name="lefttrigger" type="axis" id="2" value="1" />
                <input name="right" type="hat" id="0" value="2" />
                <input name="rightanalogdown" type="axis" id="4" value="1" />
                <input name="rightanalogleft" type="axis" id="3" value="-1" />
                <input name="rightanalogright" type="axis" id="3" value="1" />
                <input name="rightanalogup" type="axis" id="4" value="-1" />
                <input name="rightshoulder" type="button" id="5" value="1" />
                <input name="rightthumb" type="button" id="10" value="1" />
                <input name="righttrigger" type="axis" id="5" value="1" />
                <input name="select" type="button" id="6" value="1" />
                <input name="start" type="button" id="7" value="1" />
                <input name="up" type="hat" id="0" value="1" />
                <input name="x" type="button" id="2" value="1" />
                <input name="y" type="button" id="3" value="1" />
        </inputConfig>
</inputList>
lvl2:   Added known joystick Microsoft X-Box 360 pad (instance ID: 0, device index: 0)
lvl2:   EmulationStation cleanly shutting down.

I’m booting directly into RetroArch; skipping ES because it was going horribly previously. This is where the gamepad doesn’t work :frowning:


#135

Do you have a folder called “scripts” in /storage/.emulationstation ?

if not, make sure you are using v2.3.1

if yes, add this to es_input.cfg

  <inputAction type="onfinish">
    <command>/storage/.kodi/addons/script.sx05re.launcher/bin/bash /storage/.emulationstation/scripts/inputconfiguration.sh</command>
  </inputAction>

and in ES reconfigure your gamepad, it should create a retroarch config.


#136

Hi, i have on question about updating the “Addon” Release from your Sx05RE. I installed ES as AddOn over CoreElec. How do update this addon with your Release from March, 5th?! Install over?! But i made changes on the ES config, are they lost then?!

Thanks for helping.
J.


#137

I do not have a scripts folder. I did an addon update; is the mechanism the same for this as a new install?

EDIT: Yeah, bummer. Re-configured in ES despite not having scripts; RetroArch is still broken :frowning:


#138

Yo can back up up your settings and install over, but if the one that you have works for you you probably don’t need to change it. remember all these are test releases.


#139

If you don-t have the script folder you are using an older version, you need to reinstall


#140

It said Add-on updated. Any idea if we can fix this mechanism instead of a complete uninstall and clean install? I’m afraid I’m going to lose my save state (weather has been well so I haven’t had a rain day in a while).


#141

Remember these are test releases, used so I can iron out all the bugs, once this is done, hopefully reinstalling will not overwrite anything. but for now if you REALLY need the latest version you have to back up and reinstall, sorry.