T95Z max ethernet problem


#21

Please elaborare what kind of problem you are talking about regarding the USB Ethernet adaptor


#22

Hi,

don’t know if it’s related to your problem here and if it’s still existing in CoreELEC but in LibreELEC there is/was a freakin’ problem with the dhcp settings. I have both boxes mentioned here (‘Sunvell T95Z Plus’ and the ‘Alfawise H96 Pro Plus’). Both connected via wired Gbit ethernet. As soon as I change the network settings to tell the system to use a dedicated ip address I really have big issues with the network speed of both mentioned S912 boxes. If I leave the setting on ‘dhcp’ everything is working fine. Weird but true, it took me hours to find that out.
Maybe worth a try if you have also changed your network settings to a dedicated ip address in the CoreELE ui.

greetings


#23

@Menion … basically I plugged it …it got an IP address and all looked ok …I disabled wireless on the box to ensure only 1 network connection via the USB device … All using DHCP …

Still looked same with browsing SMB and NFS … told it to go update the library and the thing just hung …

I would give up on this entirely and assume it’s the box except for the fact the Android on it with Krypton Kodi is working 100% …

So 2 OS , same hardware , 1 works and 1 doesn’t …

If I can’t solve it there will be no CE for me :weary:


#24

This is strange. This evening I will test with my usb dongle. If it is confirmed then it means that we have a completely different issue here


#25

Tbh I’d happily send you my box to also check!

I’m going to mess about with different DTB.IMG files in the interim…


#26

Don’t do that, it is of no use, you will just brick the device


#27

It’s running off the SD card - I haven’t put CE onto the internal … so should be ok? No?


#28

Almost identical Hardware , EXCEPT CoreELEC is using an SD Card as Hardware.
Maybe a Crap SD Card with poor sequential Read / Write speeds.


#29

Possibly , but I doubt that … these errors manifest themselves as network reads and not disk read/writes from observation.

Class 10 SAnDisk Ultra 32gb HC I

In the earlier posts here you will that others have experienced issues with this network card …

Is it worth trying a much earlier version of CE or is that pointless?


#30

FYI - just tested out kszaq’s LibreELEC on this to see what happens.

Same issues really …

My feeling based on all this is that there is something fundamental in the base network Ethernet hardware for these boxes running under CE/LE that isn’t compatible…

Running wireless works better but tbh isn’t robust enough for my setup when the want to stream 4K content … too many buffers…

Tempted to buy another box …


#31

With NFS (or FTP) shares and a properly adjusted buffer, you can get away with 100Mbps in 99% of cases.


#32

Tried the USB-Ethernet dongle, it works perfectly


#33

Have you tried it booting from an SDCard?

And you are running it on what exactly?

I will have a go at the few things mentioned in the first few of this thread ( https://forum.libreelec.tv/thread/11877-t95z-plus-3-32gb-display-and-network-problems-under-8-90-5/ ) over on the LE forum but tbh I was sure I tried that …but will give it another go to prove I’m not going mad…


#34

Looks like it’s back to Android for me since I can’t get this thing to work … something is off but who knows what…


#35

My money is on the H/W :wink:


#36

ha ha mine isn’t since it works great under Android …its likely a driver issue somehow … works with 1 lot of software but not the other … possibly an issue with incompatible hardware & software or software alone in my view…


#37

Use Android then :+1:


#38

i am :stuck_out_tongue:


#39

I have solved the issue. We need to remove cali_val property in the dts. I have been put on the right path by Sam Nazarko of OMSC, he mentioned that the TV box hardware have always behaved bad with the standard 0x20000 value. It is possible that some box still need it, but it is time to start at least a new dts family


#40

So how do we do this or do we need to wait on a new build?