Tanix TX3 mini S905W wont boot Coreelec

Hello, so I bought this box and it wont boot Coreelec. It just boots into recovery mode.

I downloaded the right image (Tanix TX3 mini) and used the right device tree (gxl_p281_2g) but nothing happens. I tried some other device trees, I tried other versions of Coreelec and I even tried Libreelec but nothing.

I used the classic method: prepare the sd card, copy device tree and rename it, put in the sd card, hold the reset button and plug in the power cable.

Maybe try a different SD card or a USB flash drive instead.

I’ve found the odd device that won’t willingly use the toothpick method to boot to CE.

Another alternative might be the android app, Reboot to LibreELEC, which triggers rebooting to CE (on a properly formatted uSD/USB as you would with the toothpick method), from within Android. Usually once you’ve triggered the first boot to CE you can use the toothpick method afterwards.

You need to ensure dtb.img is really called dtb.img and not dtb.img.dtb
Right click on file in windows explorer.
Open properties and check file name for the above error.

also try USB storage, i had same problem with nothing working with SD card on my Mekool mk pro.

Tried both and nothing happened.

Just boots to recovery.

Checked and the file name is fine.

Tried and still the same problem.

Edit:

I got it working like this:

Tried with the first and second SD card both with the toothpick method and Reboot to LibreELEC app and it just booted to recovery. Then I tried the toothpick method with a USB stick and still it booted to recovery. I already gave up and I booted to android to install Kodi and decided that I will use Kodi from android. I went to run Play Store to download Kodi but there was Reboot to Libreelec next to it and my USB stick with Coreelec was still in it so I said fuck it and pressed it and it booted to Coreelec… unbelievable. Whats even more unbelievable that now it boots to Coreelec even from SD card…

1 Like

I tried reboot to Libreelec on one of my 905x3 boxes after you posted that but no go.
Works from usb slot only… :frowning:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice