Tanix X4 / S905X4

no the box will not boot the sdcard as default, you need press the reset inside the “spdif?” port.
once you do it then it will always be in that mode as "“default” :slight_smile:


I can confirm that the Tanix X4 is working via SD-card and toothpick method.
Just tested the Box for 25 minutes and everything worked fine like on my TX3 mini.
Shutdown, reboot, playback, connecting to my samba server… everything worked.
I took the same dtb as superceleron.
I am only using Ethernet so I can say, that Ethernet also is working without problems.

The next couple of days I gonna test reboot to internal Android and how it is doing when switching off WIFI on Android… (heard that some people had problems with disabled WIFI and Ehternet)


Does Bluetooth, VFD etc. work?
If yes what vfd.conf file was used?

Reason for questions now is that I have one on order and would like to be prepared. :smiley:

No to both.

I don’t use bluetooth so hadn’t checked that until now but it says “No Bluetooth adapter found” once you enable it.

For the VFD I have tried heaps of the config files but couldn’t find one that worked. Happy to customise a conf file if someone can point me in the right direction for determining the right parameters to use.


I think we need the following information…

This is only an example from a vfc.conf file !!!





Moving to the correct thread.

1 Like

A post was merged into an existing topic: Looking for users with no working WiFi or BT

2 posts were merged into an existing topic: Looking for users with no working WiFi or BT

I’ve been using Corelec on the X4 for a few weeks now and I have noticed that the SPDIF output doesn’t work - I’ve tried all sound devices in the settings, but no luck. It works properly in the stock Android though. Any idea what needs to be configured to make SPDIF work?

BTW I took a shot of the board if anyone’s interested.

My 4GB/32GB Tanix X4 has finally arrived from China from Banggood. All the online reviews I’ve seen of the box suggest it’s got Gigabit Ethernet. However when I booted up for the first time in Android, my Unifi Switch reports 10/100Mbs only, not Gigabit.

If I use the same cable and switch port in a Gigabit Ethernet USB3 adaptor plugged into the X4 I get Gigabit flagged so it’s not the cable or switch port - at least not obviously so.

Are there multiple versions of the Tanix X4? Are the reviews wrong?

I’ll try to boot up into CoreElec when I get some time later this week. The Tanix looks a much neater and cleaner box than the S905X4 X96 I have (the gaudy LED lighting ring on the X96 is not something I particularly value in a media player)

Do you have an link to the version you bought?

Afters doing some research on the Internet it appears there is a Tanix X4 with gigabit LAN and an unbranded X4 that looks the same but without the Tanix logo on it, which has 10/100 LAN.

Buyers beware of knock-offs…


Hi there - mine is Tanix branded with a Tanix logo on the case.

Mine too but only with a 100Mb Ethernet port i.e. no gigabit LAN port !!!

I just got a Tanix “labeled” box today and it is only 100M in Android but advertised 1000M on Amazon.

It is quite obvious, that there is a force in the universe, that is preventing you from acquiring an Android box that has gigabit Ethernet capabilities.

I am only trying to future proof myself for the new kernel since my odroid and vim devices are so much better with CE anyway.

My flavour of the Tanix X4 though is not the way to go, the TF card is hard to access, plus it is upside down like the other ports. No wifi or BT either. Don’t know about the coax SPDIF but I will return this. Their Android (ATV) doesn’t even allow network adb connections

A lot of these devices have ‘upside down’ HDMI and USB ports. The OSMC Vero 4K is very similar in that regard.

Certainly it’s preventing me from getting one. A USB 3.0 Hub with built-in Gigabit Ethernet is probably the least-worst solution I guess. The Tanix is a lot ‘subtler’ than the X96 LED light-show fest.