Testers wanted: GXL, 1GB RAM devices, Amlogic-ng

Thanks a lot to everyone for your availability, but I don’t want to be stressful or go off topic; unfortunately the suggestions didn’t work …
patience … In the meantime I bought a Trevi IP 380 V1 with 2/16 Gb and Cpu S905W; perfectly installed on CoreElec 19.2-rc2 Matrix sd (Stable) with DTB file gxl_p281_2g
Everything works perfectly. I have not tested the remote control as I use a mini usb keyboard and it works great.
Great job and thank you very much

So I have a success story to contribute. Upgraded a friend’s X96 - S905x 1GB Ram to my goto android 7.1.2 Rom and then installed CE 19 nightly (21-06-15). CE installed just fine but wasn’t terribly stable.

I figured @Garcea was on to something and tried his ATVx recommendation. I re-flashed the original garbage X96 Android 6 rom, then flashed ATVxperience v4 (Android 9) (multi wifi driver version), and finally the above mentioned CE 19 nightly. Everything worked great with the exception of one of the USB ports not working. I Searched the forum and found this gem: Bqeel M9C Max - USB OTG port not working - #13 by Portisch

Voila! All USB ports work and another aged S905x happily runs CE 19 without any issues so far. :grin:


Running 19.2-Matrix_rc2 successfully on my 1gb La Frite, so far no dramas.

For those that are running rc2 on aidan v7 firmware install on a 1gb s905x, is it your daily ce box? I find the ce rc2 is terrible performance. The default usb driver is slow and does not work with my rf keypad. I’m using an mysql db and currently have 600+ movies. I have much less tv series so it will allow me to freely browse the tv shows. But when trying to browse around movies, it would hang and restart kodi (service only not reboot).
I just can’t see this as a replacement to a stable ce 18. I an hoping that a few more release may fix this issue but I’m not holding my breath for it. It may be an upgrade to a new gen cpu and more ram.

I have two 1 GB S905X boxes running 19.2 rc2 (I also used Aidan’s ROM to upgrade them to Android 7) and they run very smoothly and better than under the previous not -ng CE 9.2.7. My USB RF keypad also works fine on them.

By chance have you restored a CE 9.2 backup on CE 19? I did a full reconfiguration from scratch on both boxes.

Really odd but i have these two edal 4k boxes and one t95x. They all behaved the exact same way. They all needed and could only flash with one aidan’s v7 firmware and nothing else to allow to boot with ng kernel ce 19.

I boot off sd so i just swap out the ng kernel ce19 with ce18. They both can boot fine with aidan’s firmware. However the performance is night and day whenit comes to browsing around in the gui. Ce19 would crash many times and extremely unstable. As long as you were able to start a movie and watch then it’s boot a problem. If anything the quality of the video is better than ce18. However with the instability of the gui i can’t replace it with ce18.

The test bed should be relatively similar. Two exact sd one loaded with ce18 and the other card ce19. Both have the same mysql configuration so the number of media should be the same.

Ce19 scraping is slower too but i just ignore it for now since it does not impact usability. My rf keypad and bt keyboard would not work properly. It would lag to respond then all of a sudden a whole slew of inputs all comes at once. Sometimes it would hang the box.

For those who noticed issue after flashing an Android 7 custom ROM, you should try the ATV Experience 4 ROM. It’s an Android Pie (9) iteration. If that still doesn’t work well then stick it out with CE 18 or buy a modern box with S905X3. Better would be to go for a SBC, less worries and workarounds.

Please let me know all possible ROM version for ATV Experience ROM (Android 9). I thought I tried all versions that was available at that time and not a single one would flash. I did finally found an Adian’s Andorid 7 that would accept and flash which was a big wow moment for me. Funny thing though after it is flash, I was able to boot into Aidan’s that one time, once I booted into CE19, it would never able to boot back into Adian’s again no mater how I try to do a reboot to internal. It would hang at the bootup logo.
It would have been nice to use all these s905x boxes since they are still quite powerful enough to run Kodi. Disappointed that CE decided only to use ng kernel for Kodi19. I guess I wring every drop from CE18.
I may just leave CE and just go with an Android base Firestick 4K running Kodi. I should be able to get the best of both world, Kodi and Android apps.

You are harsh, CE devs still support old S905X in CE 19 with an 4.9 vendor kernel. As time flies the OSes are resources demanding - faster CPU/VPU/GPU, more Ram, faster memory etc. It’s a wonder this boxes with only 1 GB of RAM are getting supported in the latest Kodi iterations.

Anyway, you should go here [ROM] atvX v4 - AndroidTV 9.0 (S905X) - forumXperience ATV 4 for S905x, search the multi wifi variant. Try to erase everything when flashing.

Here is the exact reason for the ng builds:

Good luck in your new ventures.

Thanks Garcea,
Even before you mentioned the thread. I did some digging and found all the files that support s905x atvx. I tried every single file except for the AMPAK and Samsung DDR3 file, not a single one would pass the InitError around 7% using USB Burning Tool. I assume my USB Burning Tool running on my Windows VM is working fine because I can always fix my box by reflashing the atvXperience_S905X_mxpro.img.

I remember I got that file from a Freaktab thread by minixfreak. Turns out he was one of the member working on atvx and branched out to do PoisonATV. I was able to find RedPoisonATV_V2_S905X_1GB.img file. This file was almost good. It failed at 99% when it was checking the CRC to ensure the partition was correct. But it too failed.

I did turn on debugging on Kodi and noticed when I browsed my Movie listing, the RAM would quickly getting used up to the point where it almost reach 0 then it would crash Kodi and restarts it.

I am not sure why it is aggressively caching my movie folder to use up all 700MB+ since about 300MB was currently being used for system. But to use up everything and not stop or anything.

There is some issue but I guess it is low priority. I know I only use CE because I can fully utilize my older box without having to buy new hardware. If the software is requiring me to purchase new more powerful hardware, I might just as well buy it and use whatever it comes with unless it also fail to perform. However, what I gather the Fire Stick 4K with Kodi is quite a performer without having to boot into Linux. Now I would prefer the whole Linux framework over Android. But there are advantages of having Android since every vendor has an app for it unlike an independent Linux Kodi Addon developer.

As I mentioned, I will use my old hardware until it just can’t be used no more. Even if it is CE18.

Thanks everyone for chatting. I will watch out if there is any movement on the RAM issue.

forum is down??

It appears so, probably a temporary issue. Not affiliated with them, just tried the ROMs and that’s all. :man_shrugging:

If you have S905X SoC and want to try -ng builds, the ATV ROM its still available here: ATV4 S905X ROM
Also, you could try this ROMs Aidan’s ROM. I used them only to install the bootloader and after that I manage to erase Android and write CE on emmc. Just the upgraded bootloader was necessary for me to run CE 19 on old Bqeel S905X box.


ForumXperience is back online also.


@Portisch How are things now with respect to the dtb files and the proper workings of the s905x? Are most issues solved now? Will the proper dtb files be included in the next CE stable release? And if not, is there anything i can / should do to help?

Nothing to do anymore. All is setup in nightly already and what is working in nightly should work in next release to. Most changes are already included in last 19.2-Matrix_rc2 release.

Great! Nice to know that our effort wasnt for nothing. I’ve enjoyed working with you together. Fun to have a remote session-in a vm - connected to a serial console at work, controlled from acros the globe. If at one time my assistance could contribute to the project, please let me know. I’m more then willing to help.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.