Testers wanted: GXL, 1GB RAM devices, Amlogic-ng

@Portisch Thumbs up on gxl_p231_2g, working fine on S905D - Vero4K+.

Sorry for the late reply, i was in job.
I uploaded dmesg from android and from CoreELEC 19.1-Matrix with the use of original gxl_p212_1g.dtb.
dmesg_android.txt (352.0 KB)
dmesg_CoreELEC.log (75.8 KB)

I need the dmesg from p231, not p212 as this is already working

Sorry, i changed dtb for original gxl_p231_1g.dtb (I have only black screen)
dmesg_p231_dtb.log (270.9 KB)

Thank you, i think it’s the same error like at the p212:
failed to allocate memory for node linux,meson-fb

Let me create later some new dtbs…

@9martin please try this dtb:
[gxl_p231_1g.dtb|attachment]
But i am not sure if it works now. please test and make dmesg again.

WoW! Works for me. :hugs:

dmesg_new_gxl_p231_1g.dtb .log (94.2 KB)

Thanks for the hard work!

1 Like

Thank you for testing.

I re-uploaded all dtbs again in the first post.
So only p241 and p281 1g test is missing…

The changes will be included in next nightly and the upcoming 19.2-Matrix_rc1 release.

1 Like

Tested on MXQ (the all black one with the only typing “MXQ”)
SoC: S905X
RAM: 1GB
ROM: 8GB
Ethernet: 100Mb
Android 6
internal wifi: 9082xs
Image used: CoreELEC-Amlogic-ng.arm-19.1-Matrix-Generic
With the new file gxl_p212_1g.dtb, the device does not start.
While with the night image: CoreELEC-Amlogic-ng.arm-19.2-Matrix_nightly_20210530-Generic.img.gz and the internal dtb of this image, after a couple of times it starts, but crashes.
Since there is android 6, I tried to flash Aidan’s rom, both with the pc using Amlogic_USB_Burning_Tool_v3.1.0 and with an sd using AMLogic_Burn Card Maker, but the flash doesn’t start.
Thank you so much for your effort and hard work

And when you downgrade to 20210528? It works again? Can you make a dmesg log from 20210530 please.

Was it ever booting before with Amlogic-ng?
Android 7.1 looks like minimum for Amlogic-ng project.

Hi Portish sorry for the delay in answering you and thanks for the availability.
No Amlogic-ng version worked for me. The software is installed, CE is started but after a few seconds it stops and restarts; also tested the CE image: CoreELEC-Amlogic-ng.arm-19.2-Matrix_nightly_20210601-Generic.img.
I tried to install android 7.1 Aidan’s, but none of the roms worked, not even the special build. Even now only the “S905x” image appears and android stock no longer starts. Fortunately the sd boot works. Unfortunately, I can’t log either from android or from CE (or at least I’m not so practical as to be able to do it, sorry).
I can post some photos of the box and mainboard.
However, I can confirm the installation from sd of: LibreELEC-AMLGX.arm-10.0-nightly-20210602-de9caf8-box.img with the dtb file: meson-gxl-s905x-p212; where I believe the 5.x kernel is
Thanks a lot anyway






No, this does not help. First you will need to find an booting Android 7.1 image.
Then you can try again if CE start booting. If still not I see a 4-pin hole row for a UART header.
There you are able to create a UART log what should show the reason why it is not booting.

Booting and log files from LE does not help in any way as it’s a complete different kernel.

@jimjack12 before you give up entirely, try this Android 7.1 ROM: https://mega.nz/file/e0oj0CQK#6k-GdfJp0xIuYHa24HKJtUEF_WboMMqJETjyouqmspM

I have installed it on an S905x MXQ 1G ram clone as well as a number of other S905x 1G & 2G boxes over the years.

1 Like

Thanks for that. If i understand correctly, the necessity of flashing a clean android 7 is because of in doing so the device’s bootloader gets updated and therefore CE will be able to boot from it.

Just wondering (i’m no expert): could it be possible to include the newest bootloader in a CE image and flash that CE image with amlogic usb flashtool directly to the device’s internal emmc, just as we do with android images?

Thanks a lot to everyone for your availability;
unfortunately the image of kshi is not able to flash, error at 4% like the others I have tried.
I have tried with both Aml burn tool version 2.2 and version 3.1.0.
If I don’t bother, could someone give me some other suggestions?
Thanks so much

Try this ATV Exp 4

That’s a bummer, I’m sorry to hear that it didn’t work for you.

Do you have a copy of the android 6 firmware for that box that you are able to successfully flash? A lot of flashing efforts have been thwarted in the past by a sub-par USB cable.

Try different versions of the Burning Tool, I tried several and the only one I got to work was 2.1.68. That tool is notoriously buggy.

Sadly @kshi rom also doesn’t work on my MXQ Pro 4k. Error at 99% - UBOOT/Partition bootloader/Verify partition/Error.

I found modified atvxperience rom android 7.1.2 and flashed successfully.
Power button on remote is not working so i can’t turn on device, also reset button in AV port is not working anymore.
So I used terminal emulator and “reboot update” command to boot up CoreELEC and it works.

I tried to use “inject_bl301” feature but no luck:

Using CPU type GXL (21): S805X, S805Y, S905X, S905D, S905W, S905L, S905M2
Using binary type because of CoreELEC DT-ID: Generic
Can not find the bootloader partiton: /dev/bootloader!

ceemmc tool also doesn’t work:

Parameter for block device ‘mmcblk0’ not found: ‘/sys/block/mmcblk0/size’
Failed to read eMMC size! Exit!

I know there’s no support for emmc tool so just ignore it.
But what about inject_bl301? Can I do anything to make power button on remote works?


Also something is wrong with latest nightly build. I couldn’t turn on SSH on first boot setup screen.
I did turn it on in CoreELEC Settings but after reboot it was disabled again.
On stable 19-1 Matrix build SSH works fine.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice