TPLink Archer T3U Plus/RTL8822BU-aml only using USB 2.1

I have an ODroid N2 (not plus) and last year I got a new wireless NIC to try to improve transfer speeds. I read that the T3U Plus was a supported 802.11ac model so I got that.

However, when I was transferring files I realized that it was really slow. The router is in the same room as the TV, maybe 8 feet or so away, and it looks like it’s getting full 867 Mbps PHY speed.

CoreELEC:~ # iwconfig
wlan0     IEEE 802.11AC  ESSID:"shijiazhuang"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:5.785 GHz  Access Point: 70:03:7E:10:95:B3
          Bit Rate:867 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=85/100  Signal level=-30 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I tried all four USB ports, and iperf3 was reporting something like 100Mbps maximum however.

➜  ~ iperf3 -c -p 5201 -u -b 1000m -i 10 -t 60
Connecting to host, port 5201
[  5] local port 57088 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Total Datagrams
[  5]   0.00-10.00  sec   284 MBytes   238 Mbits/sec  2199941
[  5]  10.00-20.00  sec   240 MBytes   201 Mbits/sec  1772235
[  5]  20.00-30.00  sec   234 MBytes   197 Mbits/sec  1856899
[  5]  30.00-40.00  sec   231 MBytes   193 Mbits/sec  1804758
[  5]  40.00-50.00  sec   224 MBytes   188 Mbits/sec  1685979
[  5]  50.00-60.00  sec   239 MBytes   201 Mbits/sec  1740226
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
[  5]   0.00-60.00  sec  1.42 GBytes   203 Mbits/sec  0.000 ms  0/11060038 (0%)  sender
[  5]   0.00-60.49  sec   762 MBytes   106 Mbits/sec  0.036 ms  10394885/10946883 (95%)  receiver

So I looked at the lshw ooutput and it looks like no matter which USB port I use, it always downgrades the USB to USB 2.1

       product: xHCI Host Controller
       vendor: Linux 4.9.269 xhci-hcd
       physical id: 1
       bus info: usb@1
       logical name: usb1
       version: 4.09
       capabilities: usb-2.00
       configuration: driver=hub slots=2 speed=480Mbit/s
          description: USB hub
          product: USB2.1 Hub
          vendor: GenesysLogic
          physical id: 1
          bus info: usb@1:1
          version: 93.04
          capabilities: usb-2.10
          configuration: driver=hub maxpower=100mA slots=4 speed=480Mbit/s
             description: Generic USB device
             product: 802.11ac NIC
             vendor: Realtek
             physical id: 4
             bus info: usb@1:1.4
             version: 2.10
             serial: 123456
             capabilities: usb-2.10
             configuration: driver=rtl88x2bu maxpower=500mA speed=480Mbit/s
       product: xHCI Host Controller
       vendor: Linux 4.9.269 xhci-hcd
       physical id: 2
       bus info: usb@2
       logical name: usb2
       version: 4.09
       capabilities: usb-3.00
       configuration: driver=hub slots=1 speed=5000Mbit/s
          description: USB hub
          product: USB3.1 Hub
          vendor: GenesysLogic
          physical id: 1
          bus info: usb@2:1
          version: 93.04
          capabilities: usb-3.10
          configuration: driver=hub slots=4 speed=5000Mbit/s

Could this be a driver issue? Or if it’s hardware does anyone else have a suggestion for a different 802.11ac NIC to use?

The box says USB 3.0 pretty clearly.

OK I found and followed the directions here:

And it worked! lshw is now showing up as USB3. And it looks like iperf speeds have increased 50% to 150Mbps. Still significantly below the 867 Mbps.

I know most people on here recommend using wired vs. wireless but that’s not an option for me right now as the router and the box are on opposite sides of our living room.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.