Turn off H264 hardware acceleration just for PVR streams?

I currently have H264 acceleration turned off because of the judders I get, here in the UK, when the Freeview HD channels flip between progressive and interlaced on the fly. I hope this accurately describes the problem.

My N2 handles the software decoding well and with deinterlace set to off the results are very watchable.

Is there anything I can do to just turn acceleration off for the Freeview HD channels, perhaps thro autostart.sh?

Upload a record sample for test.
All my p->i->p samples works fine on N2+

Sorry to have taken so long to reply, i was taken out of action by a different “Vid” problem.

Here’s the sample file https://easyupload.io/vvjhrv

There is a glitch right at the start and on the transition to the next advert.

On reflection, I could well have attributed the cause incorrectly, so I won’t be offended by brutal honesty. The point is though that it plays OK with H264 acceleration turned off. Ideally it would be great if it played OK with acceleration. If that’s not possible, could you address my original question.

Thank you for taking the time to look at this again.

Did you try nightly build?
I see no glitches on N2+ for your sample. Only micro glitch on switching from progressive to interlaced stream and back.

It was taken from the latest nightly build. If you can’t see it, please forget it. I have a way to eliminate it and it seems it’s only me that suffers/notices it.

I may attempt to get a clearer example at some point and I’ll revive this thread if I do.

Hello @boot2k3. Sorry for the time taken to revive this but here’s another, better example of what I see from time to time. Keep your eyes on the man’s striped shirt. (played on latest nightly on N2+)

https://easyupload.io/rbs28i

If this could be fixed, my N2 and N2+ would be perfect. Turning off hardware acceleration sort of works but there is some blurring/judder especially when end titles are scrolling up the screen.

This is expected behavior as source changes 3 times for this short period.
I see only one glitch at last change, but this is expected.
Here there is a video how it looks for me.

[1306535.495676@1]- dim:1920x1080-0x9000.

[1306536.334120@1]- dimh_patch_post_update_mc_sw:0x0->0x2

[1306536.334238@1]- dim:pre cfg:ch[0]:1306293744ms 1th source change:
[1306536.334241@1]- dim:source change:0x0/0/0/0=>0x8009/1920/1080/0
[1306536.334255@1]- dimh_patch_post_update_mc_sw:0x2->0x3

[1306547.231734@1]- dim:pre cfg:ch[0]:1306304644ms 543th source change:
[1306547.231740@1]- dim:source change:0x800b/1920/1080/0=>0x9000/1920/1080/0

[1306549.511765@1]- dim:pre cfg:ch[0]:1306306924ms 601th source change:
[1306549.511771@1]- dim:source change:0x9000/1920/1080/0=>0x8009/1920/1080/0

It’s some issue on your input signal. It shouldn’t change so much times on same video.
Only way to solve is to force to interlace in code if source changed , but it’s wrong way

Thanks for this. I’m using a Hauppauge WinTv Dual tuner and have found a post in the forum that talks about changing the running mode from isochronous to bulk. To my mind, it could be the cause of the frequent changes you describe.

Later today, when I can mess without cries of “there’s no telly”, I hope to change the operating mode. Ill report on results if I manage to do this.

1 Like

Well, when I checked, the tuner was already running in bulk mode. I’ve tried switching to Crazy Cat drivers but they were unstable and kept saying no signal. I’m back to square one now with latest kernel drivers and at a loss to know why this is happening. What perplexes me is why Tvheadend client on Firestick has no problems with the same streams.

Thank you for trying to help but I think it’s time for me to give up.

My last word on this. I have been trying multiple scenarios to try to find the problem. Amongst them I separated TVheadend server and client onto different N2 boxes to no avail. Then I read somewhere that kernel 4 had introduced something that seemed like the symptoms I was seeing. So, I tried 9.2.8 on an old S905 box I have. This uses kernel 3.14.29. In 3 days I’ve not seen a single blip when using H264 acceleration.

So, my main N2+ now acts as server for TVheadend and Plex but has been retired from TV watching duties. It’s a shame cause it’s only the H264 streams that give a problem and the onboard DAC is superb. I’m happy with this as a result and can afford the extra 5 or 6 Watts this consumes😂

P.S. Just seen that I had been guides to the same conclusion some time ago but I had forgotten this in the midst of time. Is there anywhere I can go to for a pre kernel 4 version of CoreELEC for an N2?

Short answer, no. I can say I use N2+ to watch live tv from tvh server and I have 0 (zero) problems.

1 Like