Tvheadend 4.4.14.0 install fail


#1

Hello, I´ve been running TV headend without issues for some while now. After the latest KODI and Coreelec update TVheadend would not start. I even deleted the HTSP client, in the belief that reinstalling it would solve the issue. When attempting to reinstall, a short popup message is displayed: Tvheadend installation failed.

I am a very basic user - is there anyone here that could provide me with an answer on how to get back on track?

Greatly appreciate any clues and solutions!


#2

Can you access the server?


#3

Where are you getting 4.4.14.0 as the latest I have is HTS Tvheadend 4.2.7-44 ~ CoreELEC Tvh-addon v9.1.118? Even forcing an update does not get me a more recent version.

TIA


#4

Yes even I would like to know where you have got this from because it’s not from CoreELEC.


#5

Thee are a number of TVHeadend forks knocking around, many of which are buggy.

If you want to keep up with development with versions that tend to be reliable, bookmark this.

http://build.mycvh.de/Tvh-LE9.0/

I’ve been using 1774 since it was released and works as required.


#6

We can’t be expected to diagnose and assist with problems caused by buggy addons from third party locations.


#7

I have Version 4.4.14.0 HTSP Client.
All working good.


#8

Greetings,

Dude, what interface is that?

Best regards…


#9

The server is accessible, and seems to function normally. KODI just seems to deny attempts to reinstall the HTSP client.


#10

Can´t really explain it any other way, than it is the only TVheadend HTSP client version that pops up under coreelec addons in the PVR file.


#11

Can´t really tell if it´s a buggy version. It is available from the coreelec addon file under PVRs. I guess everything would be running normally if I had not deleted the client in the first place. Rookie mistake. I have tried suggested solutions clearing the package cache, update and restart, but it still will not install.


#12

I think, we are talking about two different packages.
There is an addon for the TVH server (4.2.x) and one for the TVH client (4.4.14.x).
If you are talking about the TVH client, then please try to manually download it from here and “install from zip”:
https://relkai.coreelec.org/?dir=addons/9.1/Amlogic/arm/pvr.hts


#13

AppTV Skin from official Kodi Repository


#14

Thanks a bunch, @relkai! That solved the problem. :raised_hands: