TX3 Mini Glitch/Bug/Crash with MBAFF 1080i50 content


#1

Greetings all, and many thanks to all those involved for the hard work that has obviously gone into making coreelec the awesome bit of software it is today.

I’m somewhat new to all this - I’m an old hand with HTPCs, chromecasts, firesticks, kodi etc but the TX3 mini is my first Android tv box.

I’m in the UK, and I largely bought the box as a way to bring live TV into a room without an aerial feed at broadcast quality - I’ve got a dvbviewer server which I’ve used for years and works well using the kodi client - I’d recently discovered that the Fire tv 4k stick doesn’t properly deinterlace/process uk broadcast HD content (which I recall is MBAFF encoded) so thought I’d get a cheap android TV box and try coreelec which reports indicate works well with this.

So, my TX3 Mini arrived, I fired up CoreELEC, connected it to my dvbviewer server, and all was well - the HD content was being properly displayed and deinterlaced - for nearly 2 minutes, at which point the system would lock up hard, looping the last second of audio and not responding to the remote or keyboard.

I rebooted several times, trying coreelec from a usb stick instead of microsd, the issue remained - within 2 minutes of playback the system would hang.

I was now thinking that rather than having a cheap solution to the problem, I had a rather nice paperweight…

Anyway, the good news! In desperation I started picking through the settings and I found a solution - under settings, System- Coreelec- amlogic settings - disable deinterlacing (I turned this on).

It says that the setting requires a reboot to take effect, but my experience is that toggling this setting immediately fixed the crashes - if I turn it back off, the crash is back - and for sake of ensuring I hadn’t changed any other setting that might have fixed it, I went back to my microsd card where I hadn’t started playing with the settings, and this was still the fix!

And the best part of all, deinterlacing still appears to be working even with this setting turned on (and having rebooted) Yay!!!

So I’m not sure if you would categorise this as a bug, or a firmware/hardware glitch or what, but either way I’m glad I found a solution and thought I should report this for posterity!

My next question for anyone that got this far - what Android TV rom would people recommend for the TX3 mini?

And does a box exist that is silent, and relatively low power, but has the grunt to decode 1080 netflix streams in sw using inputstream adaptive? Or can I dream that there is an overclock that would bring this in reach for my tx3 mini? Right now the TX3 mini does literally everything I need it to in corelec, just a shame netflix and amazon can’t run at 1080… the auto refresh rate switching is a very big plus point in it’s favour though.